ZenTest 4.1.0 Released


#1

ZenTest version 4.1.0 has been released!

ZenTest provides 4 different tools: zentest, unit_diff, autotest, and
multiruby.

ZenTest scans your target and unit-test code and writes your missing
code based on simple naming rules, enabling XP at a much quicker
pace. ZenTest only works with Ruby and Test::Unit. Nobody uses this
tool anymore but it is the package namesake, so it stays.

unit_diff is a command-line filter to diff expected results from
actual results and allow you to quickly see exactly what is wrong.

autotest is a continous testing facility meant to be used during
development. As soon as you save a file, autotest will run the
corresponding dependent tests.

multiruby runs anything you want on multiple versions of ruby. Great
for compatibility checking! Use multiruby_setup to manage your
installed versions.

Changes:

4.1.0 / 2009-06-03

  • 1 major enhancement:

    • Removed all plugins I don’t want to maintain anymore. (gem inst
      autotest-rails)
  • 4 minor enhancements:

    • Added #blur to focus.rb to nuke all other test classes
    • Clear RUBYOPT before installs (balatero)
    • Removed test/unit include in zentest so we can focus on miniunit
    • sort versions for builds. (Jens W.)
  • 6 bug fixes:

    • Fixed a stupid bug when running on some versions of bash >= 3.2.x
      and using ‘&>’ in a system call. (Jens W.)
    • Fixed inconsistent test commands in autotest. (jbarnette)
    • Fixed unit_diff’s usage generation when installed as gem. (borior)
    • Fixed zentest to deal with unnamed classes. (Bill D.)
    • Removed buggy/unused -l support in unit_diff. (borior)
    • make twice to make it more resilient to makefile parallel bugs
  • http://www.zenspider.com/ZSS/Products/ZenTest/

  • http://rubyforge.org/projects/zentest/

  • removed_email_address@domain.invalid


#2

2009/6/3 Ryan D. removed_email_address@domain.invalid

ZenTest version 4.1.0 has been released!

I’m getting the following when installing stuff:

10:43 ~ $ sudo gem install ZenTest
Successfully installed ZenTest-4.1.0
1 gem installed
Installing ri documentation for ZenTest-4.1.0…
Installing RDoc documentation for ZenTest-4.1.0…
10:43 ~ $ multiruby_setup mri:tar:1.8.7
creating /home/jcoglan/.multiruby
creating build
creating install
creating versions
creating tmp
Determining latest version for 1.8.7
Fetching ruby-1.8.7-p160.tar.gz via HTTP… this might take a while.
creating /home/jcoglan/.multiruby/install/1.8.7-p160
/usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:97:in run': wrong number of arguments (1 for 2) (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:97:inbuild_and_install’
from
/usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:81:in
each' from /usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:81:inbuild_and_install’
from
/usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:80:in
chdir' from /usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:80:inbuild_and_install’
from
/usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:73:in
chdir' from /usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:73:inbuild_and_install’
from
/usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/bin/multiruby_setup:20
from
/usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/bin/multiruby_setup:10:in
each' from /usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/bin/multiruby_setup:10 from /usr/bin/multiruby_setup:19:inload’
from /usr/bin/multiruby_setup:19

I fixed it by changing Multiruby.run to this:

def self.run base_cmd, log = nil
cmd = “#{base_cmd} #{log ? “> #{log}” : “”} 2>&1”
puts “Running command: #{cmd}”
raise “ERROR: Command failed with exit code #{$?}” unless system cmd
end

I’ve filed a bug on RubyForge, and will send a patch via GitHub.

James


#3

2009/6/3 Ryan D. removed_email_address@domain.invalid

ZenTest version 4.1.0 has been released!

Having fixed Multiruby.run, I now cannot install gems – all versions
complain about a lack of ‘zlib’ – how do I fix this?

15:40 ~/projects $ multiruby_setup update:rubygems
Determining latest version for rubygems
Fetching rubygems-1.3.4.tgz via HTTP.
15:41 ~/projects $ multiruby -S gem install --no-ri --no-rdoc test-unit
rspec
building and installing 1.8.6-p368
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1
Running command: tar zxf
/home/jcoglan/.multiruby/versions/rubygems-1.3.4.tgz 2>&1
Running command: …/ruby ./setup.rb --no-rdoc --no-ri > …/log.rubygems
2>&1
building and installing 1.8.7-p160
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1
Running command: tar zxf
/home/jcoglan/.multiruby/versions/rubygems-1.3.4.tgz 2>&1
Running command: …/ruby ./setup.rb --no-rdoc --no-ri > …/log.rubygems
2>&1
building and installing 1.9.0-5
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1
building and installing 1.9.1-p129
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1

VERSION = 1.8.6-p368
CMD = ~/.multiruby/install/1.8.6-p368/bin/ruby -S gem install
–no-ri
–no-rdoc test-unit rspec

/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require': no such file to load -- zlib (LoadError) from /home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/package.rb:10
from
/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/format.rb:9
from
/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/installer.rb:11
… 11 levels…
from
/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:131:in
process_args' from /home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:102:inrun’
from
/home/jcoglan/.multiruby/install/1.8.6-p368/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:58:in
`run’
from /usr/bin/gem:21

RESULT = 256

VERSION = 1.8.7-p160
CMD = ~/.multiruby/install/1.8.7-p160/bin/ruby -S gem install
–no-ri
–no-rdoc test-unit rspec

/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require': no such file to load -- zlib (LoadError) from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/package.rb:10
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/format.rb:9
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/installer.rb:11
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:3
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:4
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:167:in
load_and_instantiate' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:88:in[]’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:144:in
find_command' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:131:inprocess_args’
from
/home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:102:in
run' from /home/jcoglan/.multiruby/install/1.8.7-p160/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:58:inrun’
from /usr/bin/gem:21

RESULT = 256

VERSION = 1.9.0-5
CMD = ~/.multiruby/install/1.9.0-5/bin/ruby -S gem install --no-ri
–no-rdoc test-unit rspec

/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/package.rb:10:in
require': no such file to load -- zlib (LoadError) from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/package.rb:10:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/format.rb:9:in
require' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/format.rb:9:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/installer.rb:11:in
require' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/installer.rb:11:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/dependency_installer.rb:3:in
require' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/dependency_installer.rb:3:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/commands/install_command.rb:4:in
require' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/commands/install_command.rb:4:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/command_manager.rb:140:in
require' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/command_manager.rb:140:inrescue in load_and_instantiate’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/command_manager.rb:132:in
load_and_instantiate' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/command_manager.rb:65:in[]’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/command_manager.rb:118:in
find_command' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/command_manager.rb:104:inprocess_args’
from
/home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/command_manager.rb:75:in
run' from /home/jcoglan/.multiruby/install/1.9.0-5/lib/ruby/1.9.0/rubygems/gem_runner.rb:39:inrun’
from /usr/bin/gem:21:in `’

RESULT = 256

VERSION = 1.9.1-p129
CMD = ~/.multiruby/install/1.9.1-p129/bin/ruby -S gem install
–no-ri
–no-rdoc test-unit rspec

/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/package.rb:10:in
require': no such file to load -- zlib (LoadError) from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/package.rb:10:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/format.rb:9:in
require' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/format.rb:9:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/installer.rb:11:in
require' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/installer.rb:11:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/dependency_installer.rb:3:in
require' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/dependency_installer.rb:3:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/commands/install_command.rb:4:in
require' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/commands/install_command.rb:4:in<top (required)>’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/command_manager.rb:140:in
require' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/command_manager.rb:140:inrescue in load_and_instantiate’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/command_manager.rb:132:in
load_and_instantiate' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/command_manager.rb:65:in[]’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/command_manager.rb:118:in
find_command' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/command_manager.rb:104:inprocess_args’
from
/home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/command_manager.rb:75:in
run' from /home/jcoglan/.multiruby/install/1.9.1-p129/lib/ruby/1.9.1/rubygems/gem_runner.rb:39:inrun’
from /usr/bin/gem:21:in `’

RESULT = 256

TOTAL RESULT = 4 failures out of 4

Passed:
Failed: 1.9.1-p129, 1.8.7-p160, 1.8.6-p368, 1.9.0-5


#4

On Jun 3, 2009, at 07:45 , James C. wrote:

2009/6/3 Ryan D. removed_email_address@domain.invalid

ZenTest version 4.1.0 has been released!

Having fixed Multiruby.run, I now cannot install gems – all versions
complain about a lack of ‘zlib’ – how do I fix this?

um… get off of ubuntu/debian and start enjoying life again? :slight_smile:

I don’t have an answer. The long and short of it is you’re missing
some packages you need. It is a common problem on ubuntu/debian and
google should point out the solution pretty easily.


#5

On Jun 3, 2009, at 03:40 , James C. wrote:

Successfully installed ZenTest-4.1.0
Fetching ruby-1.8.7-p160.tar.gz via HTTP… this might take a
while.
creating /home/jcoglan/.multiruby/install/1.8.7-p160
/usr/lib/ruby/gems/1.8/gems/ZenTest-4.1.0/lib/multiruby.rb:97:in
`run’:
wrong number of arguments (1 for 2) (ArgumentError)

fixed and released. thanks for filing a bug.