Zena CMS first public release!

After 3 years of work in my cave, I am happy to go out in the sunlight
to announce the first public beta release of zena !

In a few words:

Zena is a CMS based on ruby on rails with a very advanced xhtml based
templating language called zafu. Sites have been running in production
mode for nearly 2 years now, so it’s quite stable (more then 1340 unit

One of the most important architecture aspects of this CMS is that it
is based on Single Table Inheritance with the ability to create custom
classes from the web frontend.

More information on this release in this post from the blog:

Videos: http://zenadmin.org/426

I hope you enjoy…


On Oct 6, 2008, at 01:08 , Gaspard B. wrote:

Videos: http://zenadmin.org/426

first video is brokey.

looks impressive.
I am looking foward to testing the CMS.


Fun, source code to read!

On Oct 6, 6:09 am, “[email protected][email protected]

What is wrong with the first video ?

Have you tried watching it on vimeo: http://vimeo.com/1632587 ?

On Oct 6, 2008, at 01:47 , Gaspard B. wrote:

What is wrong with the first video ?

Have you tried watching it on vimeo: http://vimeo.com/1632587 ?

huh… it works now. I went to:


and the vimeo embedded said it wasn’t available.

Fun, source code to read!
The code started with rails 0.9.x (end 2005) and some parts reflect
this old history…

Some interesting parts:

lib/query_builder (pseudo sql query builder)
lib/parser, lib/parser/lib/rules/zafu.rb (template parser)

test/helpers/zena_parser/.yml (yaml tests for templates)
.yml (yaml tests for pseudo sql)

Do not hesitate to ask questions…


I am having problems both with Git and SVN on Vista.
Both are install correct, the problem seems to come from the

This is the svn output:
A trunk\db\init
A trunk\db\init\base
A trunk\db\init\base\help.fr.zml
A trunk\db\init\base\skins
A trunk\db\init\base\skins\default
svn: Can’t check path ‘trunk\db\init\base\skins\default\Node-
The filename, directory name, or volume label syntax is incorrect.


Damn !

I did not suspect that having stars “*” in the filenames would cause
such troubles. I cannot simply rename these files since the
name is used as the template definition:


An modes with “*” exist inside zena and are used to render special
pages (search result, admin layout, index page). The star is there so
these modes cannot be used to display arbitrary pages (ex. /
page43_*index.html will not work).

You could try to use the archive until I find a better prefix that
does not cause these problems.

The compressed version is at: http://zenadmin.org/zena.tgz

Beware though that zena has never been used on a windows box before
and you might find lots of surprises like this one. To avoid loosing
time with installation issues, I would recommend installing a simple
debian box with vmware…

You are right, it’s not smart.

What about the “+” sign ?

PS: this is ticket #223
(#223 avoid "*" in template names - zena


  • is proberly better, unless you get into trubble, with ruby since +
    is an operator…


I use, windows, osx, linux for development, just currently at my “¤”#
¤"%¤ Vista laptop…
But still it’s unsmart to have that type of filenames, they are bound
to be trubble…

But I am looking foward to play with it, more, when I get the time…


I fixed #223 by replacing the star with a plus sign. The change has
been pushed to subversion and github.