You may specify the path to the FastCGI crash log

I downloaded and installed Radiant 0.6 on my Fedora Core 4 running
Plesk 8.1that runs RubyOnRails under Apache2 using FastCGI. Other
rails programs
appear to launch properly but Radiant does not appear to even start
(i.e.
nothing was added to the Production.log)

I get the following error message:
----- BEGIN -----

#!/usr/local/bin/ruby

You may specify the path to the FastCGI crash log (a log of unhandled

exceptions which forced the FastCGI instance to exit, great for

debugging)

and the number of requests to process before running garbage

collection.

By default, the FastCGI crash log is RAILS_ROOT/log/fastcgi.crash.log

and the GC period is nil (turned off). A reasonable number of

requests

could range from 10-100 depending on the memory footprint of your app.

Example:

# Default log path, normal GC behavior.

RailsFCGIHandler.process!

# Default log path, 50 requests between GC.

RailsFCGIHandler.process! nil, 50

# Custom log path, normal GC behavior.

RailsFCGIHandler.process! ‘/var/log/myapp_fcgi_crash.log’

require File.dirname(FILE) + “/…/config/environment”
require ‘fcgi_handler’

RailsFCGIHandler.process!
----- END -----

Have you any idea what the problem could be?

dave4c03 wrote:

That is not an error message. It’s the contents of the fast cgi handler
file. Perhaps the permissions are set wrong on it?


John L.
http://wiseheartdesign.com

On 4/25/07, dave4c03 [email protected] wrote:

You may specify the path to the FastCGI crash log (a log of unhandled

exceptions which forced the FastCGI instance to exit, great for debugging)

and the number of requests to process before running garbage collection.

I see a similar problem unless I comment out the line reading:
AddHandler fastcgi-script .fcgi
In public/.htaccess

That might be worth trying.

Matt

I froze [myapp] with rake radiant:free:edge which I think put all the
code
in the [myapp] directory. I did a chown -R [user]:[group] [myapp] to
ensure
valid ownership. Next I did chmod 777 [myapp] to ensure permissions
were
not the problem. It did not solve the problem however.

I notice that numerous shebangs in the script and vendor/radiant
directories
do not properly point to Ruby, could this be the problem?

As long as the shebangs in your script/ and public/ directory are
correct, you should have no problem. While chmod 777 [myapp] will set
the correct permissions on the whole app, it will not recurse into
subdirectories. Inside the [myapp]/public/ directory, run this:

chmod +x dispatch*

That should make sure your dispatch scripts are executable.

Sean

I checked, it did recurse into the sub directories on my Fedora Core 4
system.

The shebangs in about 60 files in script and vendor/radiant appear to be
wrong! Those files have #!/usr/bin/env ruby shebangs while “which
ruby” is
/usr/local/bin/ruby. “Whereis ruby” does not list a /usr/bin/env
option. Is there a ruby program to fix them or some way to link
“/usr/bin/env ruby” to “/usr/local/bin/ruby”.

dave4c03 wrote:

I checked, it did recurse into the sub directories on my Fedora Core 4
system.

The shebangs in about 60 files in script and vendor/radiant appear to be
wrong! Those files have #!/usr/bin/env ruby shebangs while “which
ruby” is
/usr/local/bin/ruby. “Whereis ruby” does not list a /usr/bin/env
option. Is there a ruby program to fix them or some way to link
“/usr/bin/env ruby” to “/usr/local/bin/ruby”.

The /usr/bin/env ruby is equivalent to running which to see where Ruby
is installed and then running ruby. It’s possible that the env program
isn’t in /usr/bin in which case you could just replace the call with
/usr/local/bin/ruby .


John L.
http://wiseheartdesign.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs