YARV install on Mac OS X?

what to do in order being able to install YARV on Mac OS X ?

the README says :

configure blahblah

their is no configure in the directory ???

it seems configure is written by some other tool, which one ?

“U” == Une bévue [email protected] writes:

U> what to do in order being able to install YARV on Mac OS X ?

The installation say (see http://www.atdot.net/yarv/#i-4-2)

mkdir build
cd yarv
autoconf
cd …/build
…/yarv/configure --prefix=[your install dir] --program-suffix=-yarv

you need at least autoconf

p.s. : it’s my news server which has problem, or there is a problem on
the
gateway ruby-talk ==> comp.lang.ruby ? it seems to work only
comp.lang.ruby ==> ruby-talk.

Guy Decoux

ts [email protected] wrote:

The installation say (see http://www.atdot.net/yarv/#i-4-2)

mkdir build
cd yarv
autoconf
cd …/build
…/yarv/configure --prefix=[your install dir] --program-suffix=-yarv

i don’t get that on the web site :

Build and Install

:yarv/: checkout directory :build/: build directory

You need base ruby command. If your ruby command name is not “ruby”,
please set environment variable “BASENAME” as your ruby command.

$ cd build
$ …/yarv/configure --prefix=[your install dir] --program-suffix=-yarv
$ make [BASERUBY=[your base ruby command]]
$ make test (show some errors around block parameter)
$ make test-all (show 20 or some erros)
$ make install

i don’t have even a yarv directory then i did :
$ mkdir build
$ mkdir yarv
$ cd yarv
$ autoconf
autoconf: no input file
$ which autoconf
/usr/bin/autoconf

something has changed ???

p.s. : it’s my news server which has problem, or there is a problem on the
gateway ruby-talk ==> comp.lang.ruby ? it seems to work only
comp.lang.ruby ==> ruby-talk.

i’m not subscribed to ruby-talk sorry :wink:

“U” == Une bévue [email protected] writes:

U> i don’t have even a yarv directory then i did :

First retrieve the source

cache% svn co http://www.atdot.net/svn/yarv/trunk yarv
[…]
Checked out revision 522.
cache%

This will create a directory yarv

U> i’m not subscribed to ruby-talk sorry :wink:

This just mean that you’ll not receive response to your question by
someone subscribed to ruby-talk

If you don’t care (to receive a response), it’s your problem :slight_smile:

Guy Decoux

ts [email protected] wrote:

U> i don’t have even a yarv directory then i did :

First retrieve the source

cache% svn co http://www.atdot.net/svn/yarv/trunk yarv
[…]
Checked out revision 522.
cache%

This will create a directory yarv

ok thanks !

U> i’m not subscribed to ruby-talk sorry :wink:

This just mean that you’ll not receive response to your question by
someone subscribed to ruby-talk

i’m under subscribing right now :wink:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs