XML-RPC Problem?

Hello all?

I have a weird problem with xml-rpc. I’m trying to connect to a mailman
listmanager via xml-rpc with SSL enabled to get all lists from it via an
‘Mailman.listAllLists’ call (see code below). Whenever I try this I
always get an End of File Error, with the error message on the list

(104)Connection reset by peer: ap_content_length_filter:
apr_bucket_read() failed

There is no difference in what kind of rpc command I try to call. The
result is always the same. Even if I call procedures that don’t exist.
I’ve already checked if the transmitted XML code ist correct via
wireshark and a non SSL connection and everything seems to be in order.
With Perl or Python I get the lists from the server, so there seems to
be no problem with the list server.
I’ve tested the code so far only on a PPC Mac with Ruby 1.8.5 from Rudix
installed. I then tried the code on an Ubuntu Linux PC with Ruby 1.8.4
installed but only got the same error message. So it seems that this is
no problem with my mac but a generell problem with ruby or the
xmllibrary. To verify this I copied the original and older xmlrpc
library from my Mac (version 1.8.2) over the library of my recent Ruby
installation and tadaaa now it works.

Allthough I have working code now, the situation isn’t protable and very
dissatisfying. Is my code wrong or did the library change in a way I
didn’t discern? Does anyone had the same problems and a working

Here is my Code:
require ‘xmlrpc/client’


listserver =
pw = ‘mypass’
lists = listserver.call(“Mailman.listAllLists”, pw)

puts lists
rescue XMLRPC::FaultException => e
puts e.faultCode
puts e.faultString

rescue EOFError => sio
print "An error occured: "
puts sio.message

The list server is a Debian 3.1 server with apache 2.0.54 and Mailman
2.1.7 installed.