XDG v0.4.0 released


#1

= XDG 0.4 hits the streets!

http://xdg.rubyforge.org

XDG provides a module for supporting the XDG Base Directory Standard[1].

This release removes the xdg_ prefix from the instance-level method
names. Now module and instance levels are the same.

Also, data_file, config_file and cache_file have been replaced with
data_find, config_find, cache_find, data_glob, config_glob and
cache_glob.

What’s next? Well, I can’t say I’m fond of the term ‘glob’, so I may
rename that to ‘map’ or ‘collect’ (or ‘select’?) and then add the
ability to use blocks for matching too.

[1]http://standards.freedesktop.org/basedir-spec/basedir-spec-0.6.html

0.4.0 / 2008-10-26

  • Renamed instance level methods without ‘xdg_’ prefix.
  • Replace _file methods with _find and _glob methods.