Wxruby install problem

[email protected]:~$ sudo gem install wxruby
[sudo] password for pt:
Successfully installed wxruby-2.0.1-x86-linux
1 gem installed
Installing ri documentation for wxruby-2.0.1-x86-linux…
Updating class cache with 2751 classes…
Installing RDoc documentation for wxruby-2.0.1-x86-linux…
[email protected]:~$ irb
irb(main):001:0> require ‘wxruby’
LoadError: no such file to load – wxruby
from (irb):1:in require' from (irb):1 from /usr/local/ruby/bin/irb:12:in
irb(main):002:0>

could you tell me how to solvr this problem?

Hello,

irb(main):001:0> require ‘wxruby’
LoadError: no such file to load – wxruby

Looks like you should only require ‘wx’, see

http://wxruby.rubyforge.org/wiki/wiki.pl?Getting_Started

Cheers,

[email protected]:~$ sudo gem install wx
ERROR: could not find gem wx locally or in a repository
[email protected]:~$ irb
irb(main):001:0> require “wx”
LoadError:
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wxruby2.so:
symbol _ZN13wxAuiNotebook14ShowWindowMenuEv, version WXU_2.8.5 not
defined in file libwx_gtk2u_aui-2.8.so.0 with link time reference -
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wxruby2.so
from
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wx.rb:12:in
require' from /usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wx.rb:12:in<top (required)>’
from (irb):1:in require' from (irb):1 from /usr/local/ruby/bin/irb:12:in
irb(main):002:0>

what’s matter?

Pen T. wrote:

[email protected]:~$ sudo gem install wx
ERROR: could not find gem wx locally or in a repository
[email protected]:~$ irb
irb(main):001:0> require “wx”
LoadError:
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wxruby2.so:
symbol _ZN13wxAuiNotebook14ShowWindowMenuEv, version WXU_2.8.5 not
defined in file libwx_gtk2u_aui-2.8.so.0 with link time reference -
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wxruby2.so
from
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wx.rb:12:in
require' from /usr/local/ruby/lib/ruby/gems/1.9.1/gems/wxruby-2.0.1-x86-linux/lib/wx.rb:12:in<top (required)>’
from (irb):1:in require' from (irb):1 from /usr/local/ruby/bin/irb:12:in
irb(main):002:0>

what’s matter?

Looks like you are using Ubuntu Karmic… wxRuby’s binary gem doesn’t
work with Ubuntu Karmic Koala, so you’ll have to compile it yourself:
http://wxruby.rubyforge.org/wiki/wiki.pl?BuildingOnTopOfLinuxDistroPackages

Notice the --enable-shared option when compiling Ruby!

Marvin

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs