wxPython in Cygwin issue

Hi, all
I am trying to build wxPython (2.6.3.3) on Cygwin. I just wonder
if it is necessary to use configuration option --with-opengl for the
GNURadio. BTW, if someone successfully build wxPython on Cygwin
and could share his experience, that would be great (In the Gnuradio
Cygwin Wiki, wxPython is still listed as the not-tried item).

Owen Wu
ASMedia

[email protected] wrote:

   I am trying to build wxPython (2.6.3.3) on Cygwin. I just wonder

if it is necessary to use configuration option --with-opengl for the
GNURadio. BTW, if someone successfully build wxPython on Cygwin
and could share his experience, that would be great (In the Gnuradio
Cygwin Wiki, wxPython is still listed as the not-tried item).

Sorry for the delay in responding to your email.

I successfully built wxPython on Cygwin about a year ago. I don’t
recall having to use --with-opengl for it to work, though I think
there are some wxPython features that get disabled if you don’t. (I
think it’s the wxGlCanvas stuff or whatever it’s called.)

-Johnathan

Johnathan:
After choosing not to use opengl, I successfully build the
wxWidgets
under Cygwin (I think in the wx world, this is called wxGTK+), but I
can’t build
wxPython under Cygwin. I just begin to wonder if I take the wrong
approach:
because I also posted the below message to the wx-dev mailing list and
it looked
nobody did this successfully before. Johnathan, would you mind trying to
recall
how you achieved this one year ago?

Owen

Appendix: Messgae to the wx-dev mailing list

1). Related package version:
WINDOWS: Window 2000 SVR4
OS: CYGWIN_NT-5.0 Hl_Wu_pc 1.5.21(0.156/4/2) 2006-07-30 14:21 i686
Cygwin
Compiler: gcc (GCC) 3.4.4 (cygming special) (gdc 0.12, using dmd
0.125)
GTK+: 2.6.10
Python: 2.4.3
wxPython: wxPython-src-2.6.3.3
SWIG Version 1.3.29
2). Tweak about wxWidget compile
Since the Python package didn’t link the libraray
/usr/lib/python2.4/config/libpython2.4.dll.a
to the library /usr/lib/libpython2.4.a, the compile process for wxWidget
would encounter
link error. After fixing this, the wxWidget compilation is ok.

3). error message about wxPython compilation

python setup.py build
Found wx-config: /cygdrive/c/Home/HL_Wu/gr/bin/wx-config
Using flags: --toolkit=gtk2 --unicode=no --version=2.6
Preparing CORE…
Preparing STC…
Preparing GIZMOS…
Preparing ANIMATE…
running build
running build_py
copying wx/version.py -> build-gtk2/lib.cygwin-1.5.21-i686-2.4/wx
copying wx/build/build_options.py ->
build-gtk2/lib.cygwin-1.5.21-i686-2.4/wx/build
copying wx/build/config.py ->
build-gtk2/lib.cygwin-1.5.21-i686-2.4/wx/build
running build_ext
building ‘core’ extension
c++ -shared -Wl,–enable-auto-image-base
build-gtk2/temp.cygwin-1.5.21-i686-2.4/src/helpers.o
build-gtk2/temp.cygwin-1.5.21-i686-2.4/src/gtk/_core_wrap.o
-L/usr/X11R6/lib -L/cygdrive/c/Home/HL_Wu/gr/lib -L. -lwx_gtk2d_xrc-2.6
-lwx_gtk2d_html-2.6 -lwx_gtk2d_adv-2.6 -lwx_gtk2d_core-2.6
-lwx_based_xml-2.6 -lwx_based_net-2.6 -lwx_based-2.6 -lpython2.4 -o
build-gtk2/lib.cygwin-1.5.21-i686-2.4/wx/core.dll
build-gtk2/temp.cygwin-1.5.21-i686-2.4/src/helpers.o: In function
_Z16wxPyGetWinHandleP8wxWindow': /cygdrive/d/Asmedia/FM/USRP/installation/kd7lmo/package/wxPython-src-2.6.3.3/wxPython/src/helpers.cpp:1931: undefined reference to_g_type_check_instance_cast’
/cygdrive/d/Asmedia/FM/USRP/installation/kd7lmo/package/wxPython-src-2.6.3.3/wxPython/src/helpers.cpp:1931:
undefined reference to _gdk_x11_drawable_get_xid' /cygdrive/d/Asmedia/FM/USRP/installation/kd7lmo/package/wxPython-src-2.6.3.3/wxPython/src/helpers.cpp:1931: undefined reference to_gdk_x11_drawable_get_xid’
collect2: ld returned 1 exit status
error: command ‘c++’ failed with exit status 1

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs