wxPython 2.8.8.0 and cygwin installation failure

– Hello,

After searching the mailing list archive, I’m looking for help with
wxPython 2.8.8.0 installation failures at step (9) of
http://www.gnuradio.org/trac/wiki/wxPythonCygwin. (I’m using python 2.5
and swig 1.3.34). The setup command is:

python setup.py build_ext --inplace WXPORT=msw COMPILER=cygwin
BUILD_GLCANVAS=0 BUILD_GIZMOS=0 UNICODE=0

The error message was an undefined reference building ‘controls
extension:
g++ -mcygwin -shared -s
build/temp.cygwin-1.5.25-i686-2.5/src/msw/_controls_wrap.o
build/temp.cygwin-1.5.25-i686-2.5/src/msw/controls.def
-L/usr/local/lib

undefined reference to `__imp___ZTV23wxDatePickerCtrlGeneric’ …

followed by other similar errors and then:

collect2: ld returned 1 exit status
error: command ‘g++’ failed with exit status 1

Had the same failure multiple times on 2 different machines, so help on
this would be much appreciated!

Michael

Michael,

Even I had a similar problem. When I reverted back to wxPython
2.8.7.1, binutils 20060817-1 and swig 1.3.31 it was fine. So unless
you require 2.8.8.0 (or other combination) for some specific reason,
this is the easiest workaround.

Nagaraj

Hello, Nagaraj,

Thanks very much for this information - I had not thought of trying the
earlier version of swig 1.3.31. I have searched for wxPython 2.8.7.1
but
have, so far, only found 2.8.8.0 (but I’ll find the earlier version
somewhere!)

Best regards,

Michael

Michael,

if you are still searching for wxPython 2.8.7.1, its here

https://sourceforge.net/project/showfiles.php?group_id=10718

Nagaraj

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs