WX GUI Waterfall Sink not working if a Ettus GNU Radio binary and UHD binary is installed

I need your help:

I have tried since several weeks to install GNU Radio and the USRP N210
with FPGA version 9 on different Ubuntu and Fedora versions with always
the problem that the waterfall sink is not working.
I tried several ubuntu versions (11.04, 11.10 (32 bit and 64bit) ) and
Fedora 16 and always had the problem that the waterfall sink was not
working.

  1. First I installed a fresh Ubuntu 11.10 in VMware Player (I tried it
    also on a Linux partition on my harddisk, same problem)

  2. Then I installed the runtime dependencies with the instruction from
    http://code.ettus.com/redmine/ettus/projects/uhd/wiki/GNURadio_Linux

sudo apt-get install python python-wxgtk2.8 pyqt4-dev-tools
python-qwt5-qt4 python-numpy libboost-all-dev libusb-1.0.0-dev

  1. Next I downloaded the UHD binaries and installed it with the Ubuntu
    Software Center
    (I need uhd_003.004.004-release because this is the last one that works
    with the N210 with FPGA version 9.)
    http://files.ettus.com/binaries/uhd_stable/releases/uhd_003.004.004-release/uhd_003.004.004-release_Ubuntu-11.10-i686.deb

  2. Then I downloaded GNU Radio binary and installed it also with the
    Ubuntu Software Center (I tried several different releases)
    http://files.ettus.com/binaries/gnuradio/latest_stable/gnuradio_3.6.2-38_Ubuntu-11.10-i686.deb

After that I started GRC and then made a simple program ( “Signal
Source” + “Throttle” + “WX GUI Waterfall Sink”).
Now the error: The Waterfall plot shows only a blue window without any
signal and no control buttons. (The USRP N210 is working fine with this
installation).

  1. Then I decided to use the build-gnuradio script (again in VMware with
    a fresh ubuntu 11.10)
    wget http://www.sbrac.org/files/build-gnuradio && chmod a+x
    ./build-gnuradio && ./build-gnuradio

With this build script the waterfall sink works in GNU Radio as it
should be, but GNU Radio is not working together with my USRP N210.
Thebuild script installes the UHD driver 003_005_000 which requires in
the USRP N210 the FPGA version 10, but my N210 has the FPGA version 9,
so this combination is not working.
I do not want to update the N210 firmware because I bought also the USB
Live Linux GNU Radio Stick and this requires FPGA version 9 of the N210.

  1. Then I tried the following
    wget http://www.sbrac.org/files/build-gnuradio && chmod a+x
    ./build-gnuradio && ./build-gnuradio -ut release_003_004_004
    but this time it stopped the build script in the part were it displays
    “Fetching and installing FPGA/Firmware images via wget…”

So I have to find out how to modify either the build-gnuradio script
that it uses the UHD driver 003.004.004or I should find out how to fix
the bug in the binary installation.
Any help is welcome.

Manfred

The auto-firmware-fetcher didn’t exist in earlier versions of UHD. The
build-gnuradio script doesn’t know this.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs