Wrong ELF Class: ELFCLASS32 (Ubuntu 14.04 64-bit)

Hello,

I am having trouble installing GNURadio on Ubuntu 14.04, 64-bit edition.
I have used the information from the gnuradio install wiki to install
using apt-get:

sudo apt-get -y install git-core cmake g++ python-dev swig
pkg-config libfftw3-dev libboost1.55-all-dev libcppunit-dev
libgsl0-dev
libusb-dev libsdl1.2-dev python-wxgtk2.8 python-numpy
python-cheetah python-lxml doxygen libxi-dev python-sip
libqt4-opengl-dev libqwt-dev libfontconfig1-dev libxrender-dev
python-sip python-sip-dev

When running the gnuradio-companion app I get the standard error telling
me Could not load GNURadio, Check LD_LIBRARY_PATH and PYTHONPATH
When I echo $LD_LIBRARY_PATH, I get /usr/local/lib
When I echo $PYTHONPATH, I get /usr/local/lib/python2.7/dist-packages

When I run python from the command line and run from gnuradio import gr
I get the error:
ImportError:
/usr/local/lib/python2.7/dist-packages/gnuradio/gr/_gnuradio_core_runtime.so:
wrong ELF class: ELFCLASS32.

I think this is a 32/64-bit issue but I am not sure how to resolve it.
When I build my own library and do import howto from python, everything
seems to work fine.

Any help would be appreciated!
-Ben

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs