Worker process exited on signal 11

Today is the third time within the last week that the nginx server
crashed
down, causing the website to only return “502 Bad Gateway” errors. In
the
error log, I can find the following line:

2014/04/24 05:11:53 [alert] 32094#0: worker process 32095 exited on
signal
11

I have searched for other users having the same error message, but
usually
it was caused by some custom plugin they installed. I don’t use any
plugins
(by that I mean I use debian’s stable repository of the “nginx-full”
package. I’m not sure if they deliver some custom plugins by default).

What could be causing the issue for me?

#nginx -v
nginx version: nginx/1.2.1

#nginx -V
nginx version: nginx/1.2.1
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx
–conf-path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log
–http-client-body-temp-path=/var/lib/nginx/body
–http-fastcgi-temp-path=/var/lib/nginx/fastcgi
–http-log-path=/var/log/nginx/access.log
–http-proxy-temp-path=/var/lib/nginx/proxy
–http-scgi-temp-path=/var/lib/nginx/scgi
–http-uwsgi-temp-path=/var/lib/nginx/uwsgi
–lock-path=/var/lock/nginx.lock
–pid-path=/var/run/nginx.pid --with-pcre-jit --with-debug
–with-http_addition_module --with-http_dav_module
–with-http_geoip_module
–with-http_gzip_static_module --with-http_image_filter_module
–with-http_realip_module --with-http_stub_status_module
–with-http_ssl_module --with-http_sub_module --with-http_xslt_module
–with-ipv6 --with-sha1=/usr/include/openssl
–with-md5=/usr/include/openssl
–with-mail --with-mail_ssl_module
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-auth-pam
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-echo
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-upstream-fair
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-dav-ext-module

#uname -a
Linux [hostname removed] 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64
GNU/Linux

nginx.conf
user www-data;
worker_processes 8;
pid /var/run/nginx.pid;

events {
worker_connections 16384;
# multi_accept on;
}

worker_rlimit_nofile 32768;

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 5;
    types_hash_max_size 2048;
    server_tokens off;

    server_names_hash_bucket_size 64;
    server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_buffers 16 8k;
    gzip_comp_level 6;
    gzip_http_version 1.1;
    gzip_min_length 10;
    gzip_types text/plain text/css image/png image/gif image/jpeg

application/json application/x-javascript text/xml application/xml
application/xml+rss text/javascript image/x-icon;
gzip_vary on;
gzip_proxied any;
gzip_disable “MSIE [1-6].(?!.*SV1)”;

    ##
    # Proxy Settings
    ##

    proxy_send_timeout 90;
    proxy_read_timeout 90;
    proxy_buffer_size 4k;
    proxy_buffers 4 32k;
    proxy_busy_buffers_size 64k;
    proxy_temp_file_write_size 64k;

    include /etc/nginx/conf.d/*.conf; # there is no file in that dir
    include /etc/nginx/sites-enabled/*; # only some files with 

pretty
basic server{} blocks
}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,249524,249524#msg-249524

Hello!

On Thu, Apr 24, 2014 at 06:26:37AM -0400, Lintu wrote:

package. I’m not sure if they deliver some custom plugins by default).
As per “nginx -V” provided, there are at least 4 3rd party modules
compiled in:

–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-auth-pam
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-echo
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-upstream-fair
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-dav-ext-module

Besides that, you are using 1.2.1 which is a long obsolete version
from a legacy 1.2.x branch. It is recommended to upgrade at least
to latest stable release, see http://nginx.org/en/download.html.


Maxim D.
http://nginx.org/

Thanks, I’ll try to get our servers upgraded in the next few days :slight_smile:

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,249524,249577#msg-249577

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs