Worker process (cache manager process) exiting on signal 11

I’ve compiled nginx 1.3.11 on my RaspberryPI (512MB) running Debian
Wheezy/ARM, and all appears to be quite okay, that is until nginx is
getting
fired up, then it’s aborting with some error message.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2013/02/09 19:39:17 [notice] 32149#0: using the “epoll” event method
2013/02/09 19:39:17 [debug] 32149#0: counter: 40157080, 1
2013/02/09 19:39:17 [notice] 32149#0: nginx/1.3.12
2013/02/09 19:39:17 [notice] 32149#0: built by gcc 4.6.3 (Debian
4.6.3-14+rpi1)
2013/02/09 19:39:17 [notice] 32149#0: OS: Linux 3.2.27+
2013/02/09 19:39:17 [notice] 32149#0: sysctl(KERN_RTSIGMAX): 0
2013/02/09 19:39:17 [notice] 32149#0: getrlimit(RLIMIT_NOFILE):
1024:4096
2013/02/09 19:39:17 [debug] 32151#0: write: 6, BED7FA58, 6, 0
2013/02/09 19:39:17 [debug] 32151#0: setproctitle: “nginx: master
process
nginx”
2013/02/09 19:39:17 [notice] 32151#0: start worker processes
2013/02/09 19:39:17 [debug] 32151#0: channel 3:6
2013/02/09 19:39:17 [notice] 32151#0: start worker process 32152
2013/02/09 19:39:17 [debug] 32151#0: channel 7:8
2013/02/09 19:39:17 [notice] 32151#0: start cache manager process 32153
2013/02/09 19:39:17 [debug] 32151#0: pass channel s:1 pid:32153 fd:7 to
s:0
pid:32152 fd:3
2013/02/09 19:39:17 [debug] 32151#0: channel 9:10
2013/02/09 19:39:17 [notice] 32151#0: start cache loader process 32154
2013/02/09 19:39:17 [debug] 32151#0: pass channel s:2 pid:32154 fd:9 to
s:0
pid:32152 fd:3
2013/02/09 19:39:17 [debug] 32151#0: pass channel s:2 pid:32154 fd:9 to
s:1
pid:32153 fd:7
2013/02/09 19:39:17 [debug] 32151#0: sigsuspend
2013/02/09 19:39:18 [notice] 32151#0: signal 17 (SIGCHLD) received
2013/02/09 19:39:18 [alert] 32151#0: worker process 32152 exited on
signal
11
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [alert] 32151#0: cache manager process 32153 exited
on
signal 11
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [alert] 32151#0: cache loader process 32154 exited
on
signal 11
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
2013/02/09 19:39:18 [debug] 32151#0: shmtx forced unlock
:
:
:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

‘uname -a’ results in

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Linux myhost 3.2.27+ #250 PREEMPT Thu Oct 18 19:03:02 BST 2012 armv6l
GNU/Linux
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

‘nginx -V’ output

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
TLS SNI support enabled
configure arguments: --prefix=/usr/local
–conf-path=/usr/local/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log
–pid-path=/var/run/nginx/nginx.pid --lock-path=/var/run/nginx/nginx.lck
–user=www --group=www --with-rtsig_module --with-select_module
–with-poll_module --with-file-aio --with-ipv6 --with-http_ssl_module
–with-http_realip_module --with-http_addition_module
–with-http_xslt_module --with-http_image_filter_module
–with-http_geoip_module --with-http_sub_module --with-http_dav_module
–with-http_flv_module --with-http_mp4_module --with-http_gunzip_module
–with-http_gzip_static_module --with-http_random_index_module
–with-http_secure_link_module --with-http_degradation_module
–with-http_stub_status_module --with-http_perl_module --with-mail
–with-mail_ssl_module --http-log-path=/var/log/nginx/access.log
–http-client-body-temp-path=/var/tmp/nginx/client
–http-proxy-temp-path=/var/tmp/nginx/proxy
–http-fastcgi-temp-path=/var/tmp/nginx/fastcgi
–http-uwsgi-temp-path=/var/tmp/nginx/uwsgi
–http-scgi-temp-path=/var/tmp/nginx/scgi --with-pcre --with-pcre-jit
–with-debug --add-module=/data/src/nginx/modules/ngx_devel_kit
–add-module=/data/src/nginx/modules/nginx-rtmp-module
–add-module=/data/src/nginx/modules/lua-nginx-module
–add-module=/data/src/nginx/modules/nginx-upload-progress-module
–add-module=/data/src/nginx/modules/ngx_auto_lib
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236043,236043#msg-236043

Hello!

On Sat, Feb 09, 2013 at 01:40:24PM -0500, Sil68 wrote:

I’ve compiled nginx 1.3.11 on my RaspberryPI (512MB) running Debian
Wheezy/ARM, and all appears to be quite okay, that is until nginx is getting
fired up, then it’s aborting with some error message.

[…]

–http-scgi-temp-path=/var/tmp/nginx/scgi --with-pcre --with-pcre-jit
–with-debug --add-module=/data/src/nginx/modules/ngx_devel_kit
–add-module=/data/src/nginx/modules/nginx-rtmp-module
–add-module=/data/src/nginx/modules/lua-nginx-module
–add-module=/data/src/nginx/modules/nginx-upload-progress-module
–add-module=/data/src/nginx/modules/ngx_auto_lib

Are you able to reproduce the problem without 3rd party modules?

If yes, please follow the instructions here to obtain a coredump
and a backtrace:

http://wiki.nginx.org/Debugging


Maxim D.
http://nginx.com/support.html

Just re-added
“–add-module=/data/src/nginx/modules/nginx-upload-progress-module” and
it’s
still working! :slight_smile:

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236043,236060#msg-236060

Re-activating this module
“–add-module=/data/src/nginx/modules/nginx-rtmp-module” causes the
signal
11 terminations

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236043,236062#msg-236062

That is, I’ve de-activated all 3rd party modules, re-compiled nginx
(1.3.12), and everything was fine!

Then, next iteration, adding the upload progress module again,
re-compile,
test, cool! :slight_smile:

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236043,236061#msg-236061

Re-activating “–add-module=/data/src/nginx/modules/lua-nginx-module”
works,
too!

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236043,236064#msg-236064

Finally re-added “–add-module=/data/src/nginx/modules/ngx_devel_kit”
and
all is peachy!

So apparently there’s some issue with the rtmp module.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236043,236066#msg-236066

Re-adding " --add-module=/data/src/nginx/modules/ngx_auto_lib" also
works
perfectly fine!

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236043,236065#msg-236065

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs