Wordpress Permalinks

Howdy.

So I am trying to get permalinks to work with Wordpress. I have read a
few articles/blog posts but still no luck. The permalink structure I am
trying to use is:

http://mydomain.com/wp/index.php/2012/02/sample-post/

Here is the configuration block that I am currently using that is
important:

permalinks currently not working with this

location ~ .php$ {
include /etc/nginx/fastcgi_params;
fastcgi_intercept_errors off;
fastcgi_index index.php;

 try_files $uri $uri/ /index.php?q=$uri&$args;

 # tried this as well, but still doesn't work
 #
 #if (!-e $request_filename) {
 #  rewrite ^.*$ /index.php last;
 #}

 fastcgi_pass php1.local.mydomain.com:9000;

}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,222511,222511#msg-222511

On Fri, Feb 17, 2012 at 6:10 AM, justin [email protected] wrote:

Howdy.

So I am trying to get permalinks to work with Wordpress. I have read a
few articles/blog posts but still no luck. The permalink structure I am
trying to use is:

http://mydomain.com/wp/index.php/2012/02/sample-post/

I believe it’s easier to use this structure:

http://mydomain.com/wp/2012/02/sample-post/

(I don’t know why wordpress doesn’t offer this form for nginx by
default)

Anyway, you need to move try_files outside location ~ .php$ block.
You also need split path info (and remove $ to match
/wp/index.php/2012/02/sample-post/) or add one more location block to
specifically handle the url.


nginx mailing list
[email protected]
http://mailman.nginx.org/mailman/listinfo/nginx


O< ascii ribbon campaign - stop html mail - www.asciiribbon.org

On 02-16 18:10, justin wrote:

 #if (!-e $request_filename) {
 #  rewrite ^.*$ /index.php last;
 #}

 fastcgi_pass php1.local.mydomain.com:9000;

}

this is a solution i found for running wordpress behind nginx and it
works :slight_smile:

location / {
set $rewrite_to_php “true”;
if ( -f $request_filename) {
set $rewrite_to_php “false”;
}
if ( -d $request_filename) {
set $rewrite_to_php “false”;
}
if ( $rewrite_to_php = “true” ) {
rewrite ^(.*)$ /index.php?q=$1 last;
break;
}
}

location ~* .(jpg|jpeg|gif|css|png|js|ico|html)$ {
expires max;
}

location ~* .php$ {
include /etc/nginx/fastcgi_params;
fastcgi_index index.php;
fastcgi_pass 127.0.0.1:9000;
}

if you depend on try_files you might change the “location /” section
this way:

location / {
try_files $uri $uri/ /index.php?q=$1;
}

i didn’t test it, but as written in the wiki, this should work also :slight_smile:

http://wiki.nginx.org/HttpCoreModule#try_files

bye MUH!


;;,
)…(
=_)
(oo)| |

This article might be of interest:

http://www.howtoforge.com/running-wordpress-on-nginx-lemp-on-debian-squeeze-ubuntu-11.04

It’s using the following permalink structure:
/%year%/%monthnum%/%day%/%postname%/
But I think the other options should work as well.

----- Original Message -----
From: “justin” [email protected]
To: [email protected]
Sent: Friday, February 17, 2012 12:10 AM
Subject: Wordpress Permalinks

Falko,

Thanks for the link, that worked, got permalinks going. Whoot.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,222511,222529#msg-222529

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs