WinXP, no braces in irb


#1

Hi,

I just started learning ruby. Installed on WinXP. Opened a command
window. Whenever I type a brace it appears on the creen. After typing
irb no more braces… Why? What can I do?? TIA for any help.


#2

On 12/22/05, klausa removed_email_address@domain.invalid wrote:

The same goes for square brackets and the baclslash. I am using a
german keyboard. But the german umlauts (characters with two dots on
top) appear in irb when I type them on the keyboard. Any ideas?

This has come up several times in the past. I don’t remember what the
resolution status is, but try searching for “keyboard irb” on google
groups for comp.lang.ruby. Here’s a link:

http://groups.google.com/group/comp.lang.ruby/search?q=keyboard+irb

Jacob F.


#3

On Thu, 22 Dec 2005 23:26:27 +0100, klausa removed_email_address@domain.invalid
wrote:

Hi,

I just started learning ruby. Installed on WinXP. Opened a command
window. Whenever I type a brace it appears on the creen. After typing
irb no more braces… Why? What can I do?? TIA for any help.

The same goes for square brackets and the baclslash. I am using a
german keyboard. But the german umlauts (characters with two dots on
top) appear in irb when I type them on the keyboard. Any ideas?


#4

klausa schrieb:

On Thu, 22 Dec 2005 23:26:27 +0100, klausa removed_email_address@domain.invalid

I just started learning ruby. Installed on WinXP. Opened a command
window. Whenever I type a brace it appears on the creen. After typing
irb no more braces… Why? What can I do?? TIA for any help.

The same goes for square brackets and the baclslash. I am using a
german keyboard. But the german umlauts (characters with two dots on
top) appear in irb when I type them on the keyboard. Any ideas?

Well, you have to configure some some things for it. Sadly. Here are the
steps that worked for me.

  1. Create a file “.inputrc”

First you have to create an .inputrc in your home dir to configure the
mappings for the braces, and so on. Your homedir is here:

C:\Dokumente und Einstellungen<Username on Windpows>

And the content should be:

“\M-[”: “[”
“\M-]”: “]”
“\M-{”: “{”
“\M-}”: “}”
“\M-\”: “\”
“\M-|”: “|”
“\M-@”: “@”
“\M-~”: “~”

  1. Activate readline in irb

In the same directory create a .ircrb file with the following content.

require ‘irb/completion’
ARGV.concat [ “–readline”, “–prompt-mode”, “simple” ]

  1. Setting set HOME environment variable.

The last step is to set a “Umgebungsvariable” :slight_smile: /Environment variable
HOME the before mentioned diretory/path.

Afterwards it works fine for me.

Best regards,
Oliver