Windows release

A few questions for the windows release:

I managed to compile some of the bindings with MinGW like described
here:
http://ruby-gnome2.sourceforge.jp/hiki.cgi?compile_mingw

  1. Is it possible to compile it for a many ruby versions?
    I compiled with 1.8.6-patchlevel 111, but throw out a procedure entry
    point error on a different machine with 1.8.6-patchlevel 0

Will it work with never versions if I compile against a previous
version?

  1. How was the exe-installer done? Can you provide information how to
    make one?

Best Regards,
Joachim G.

Hi,

In [email protected]
“[ruby-gnome2-devel-en] Windows release” on Fri, 14 Mar 2008 19:09:36
+0100,
Joachim G. [email protected] wrote:

  1. How was the exe-installer done? Can you provide information how to
    make one?

Check this:
http://ruby-gnome2.svn.sourceforge.net/viewvc/ruby-gnome2/win32installer/trunk/

Thanks,

kou

Joachim G. wrote:

A few questions for the windows release:
2. How was the exe-installer done? Can you provide information how to
make one?

The NSIS script should be in the SVN repo. Just get the “compiler” from
nsis.sourceforge.net, and see if it still compiles.

  • Phillip G.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs