Windows issue: 'cmd' is not recognized


#1

Fellas,
One of my Rawr users is having problems setting up JRuby in his
Windows environment. jruby seems to be on the path. I’ve seen some
other users with the same error. On my XP instance 1.3.0 seems to work
just fine.
Perhaps this is a Vista issue?

Here’s a link to the original discussion:
http://kenai.com/projects/monkeybars/forums/forum/topics/863-Rawr-installation-problem?

Logan B.
removed_email_address@domain.invalid
http://www.logustus.com


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

Hellow there,
I am the user, and I am using XP not Vista like Logan said.
Adrian


#3

Logan B. said:

One of my Rawr users is having problems setting up JRuby in his Windows
environment. jruby seems to be on the path. I’ve seen some other users
with the same error. On my XP instance 1.3.0 seems to work just fine.
Perhaps this is a Vista issue?

Yup, I have an XP vm running JRuby HEAD without any issues.

I notice that jruby.bat mentions cmd.exe, which presumably is the source
of the problem. cmd.exe exists in Vista, so possibly it’s a permissions
problem.

I know zip about Vista, but wasn’t there something about MS replacing
cmd.exe with PowerShell. might have something to
do with it.


Best,
Marc

“Change requires small steps.”


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#4

marc wrote:

of the problem. cmd.exe exists in Vista, so possibly it’s a permissions
problem.

I know zip about Vista, but wasn’t there something about MS replacing
cmd.exe with PowerShell. might have something to
do with it.

Yes, I suppose I’d try these steps:

  1. Try to run cmd in the same shell after jruby -v fails
  2. Try to run cmd bin/jruby.bat (or whatever the command line would be)
  3. Try to run cmd -c -jar lib/jruby.jar -v
  4. Copy cmd.exe to current dir and run jruby -v

I noticed none of the Windows system directories show up in the user’s
PATH…not sure if that’s likely to be a problem or not, but it seemed
weird.

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#5

MS Windows/Vista is just weird in general

On Fri, Jun 5, 2009 at 2:29 PM, Charles Oliver N.
removed_email_address@domain.invalid wrote:

  1. Try to run cmd in the same shell after jruby -v fails

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#6

Logan B. said:

Fellas,
One of my Rawr users is having problems setting up JRuby in his Windows
environment. jruby seems to be on the path. I’ve seen some other users
with the same error. On my XP instance 1.3.0 seems to work just fine.
Perhaps this is a Vista issue?

Here’s a link to the original discussion:
http://kenai.com/projects/monkeybars/forums/forum/topics/863-Rawr-
installation-problem?

I’ve also pushed a fix for the other problem:

Downloading jruby-complete.jar. This may take a moment…
C:Ruby/lib/ruby/1.8/fileutils.rb:505:in `rename’: Permission denied -
jruby-complete.jar or lib/java/jruby-complete.jar (Errno::EACCES)


Best,
Marc

“Change requires small steps.”


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#7

Jay McGaffigan said:

MS Windows/Vista is just weird in general

Taken as read.


Best,
Marc

“Change requires small steps.”


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#8

marc wrote:

http://kenai.com/projects/monkeybars/forums/forum/topics/863-Rawr-

installation-problem?

I’ve also pushed a fix for the other problem:

Downloading jruby-complete.jar. This may take a moment…
C:Ruby/lib/ruby/1.8/fileutils.rb:505:in `rename’: Permission denied -
jruby-complete.jar or lib/java/jruby-complete.jar (Errno::EACCES)

Yeah, that definitely sounds like a UAC issue. Try turning it off.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#9

I noticed recently that UAC in Vista can screw up file access, so you
might want to at least give it a try even though that might not be it (I
use OS X at work, but Vista often at home- wish I could afford a Mac).

http://lifehacker.com/software/vista/windows-vista-tip--disable-annoying-need-your-permission-to-continue-prompts-230866.php

In Control Panel, go to the Security Center. On the left hand side,
click the “Change the way Security Center alerts me” and choose “Don’t
notify me and don’t display the icon (not recommended)” as shown.

Gary

Logan B. wrote:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#10

After trying turning off UAC, you can also right-click on executables to
specify that they should be run in XP, Win98, etc. emulation mode.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#11

On Jun 5, 2009, at 1:21 PM, marc wrote:

I’ve also pushed a fix for the other problem:

Downloading jruby-complete.jar. This may take a moment…
C:Ruby/lib/ruby/1.8/fileutils.rb:505:in `rename’: Permission denied -
jruby-complete.jar or lib/java/jruby-complete.jar (Errno::EACCES)

This is a fix for Rawr? I don’t see it in the Rawr changelog. If this
is for Rawr, where might I find it?

Logan B.
removed_email_address@domain.invalid
http://www.logustus.com


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#12

I don’t understand from you in wich directories to change to run those
comands’
For bin/jruby.bat to cd… to JRuby directory?
And for in the java or jdk directory?
But I am in XP not Vista!
And yes, sometime ago I deleted by mistake the windows directories, but
now I fixed:
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Ruby\bin;C:\Program
Files\Java\jdk1.6.0_11\bin;C:\Program Files\Apache Software
Foundation\Tomcat 6.0\bin;C:\Program
Files\QuickTime\QTSystem;C:\Program Files\MySQL\MySQL Server
5.1\bin;C:\jruby-1.3.0\bin;C:\Program Files\MSI\DualCoreCenter

Now when jruby -v I get: The system cannot find the path specified.
I tried both jruby-bin-1.3.0.zip and jruby-src-1.3.0.zip. With wich one
to go?
Adrian

Charles Oliver N. wrote:

marc wrote:

of the problem. cmd.exe exists in Vista, so possibly it’s a permissions
problem.

I know zip about Vista, but wasn’t there something about MS replacing
cmd.exe with PowerShell. might have something to
do with it.

Yes, I suppose I’d try these steps:

  1. Try to run cmd in the same shell after jruby -v fails
  2. Try to run cmd bin/jruby.bat (or whatever the command line would be)
  3. Try to run cmd -c -jar lib/jruby.jar -v
  4. Copy cmd.exe to current dir and run jruby -v

I noticed none of the Windows system directories show up in the user’s
PATH…not sure if that’s likely to be a problem or not, but it seemed
weird.

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#13

Gary W. said:

Here’s a link to the original discussion:

Yeah, that definitely sounds like a UAC issue. Try turning it off.

This problem happens on XP too. Windows is very persistent at holding on
to files, so you sometimes have to “coerce” it let go.


Best,
Marc

“Change requires small steps.”


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#14

Logan B. said:

On Jun 5, 2009, at 1:21 PM, marc wrote:

I’ve also pushed a fix for the other problem:

Downloading jruby-complete.jar. This may take a moment…
C:Ruby/lib/ruby/1.8/fileutils.rb:505:in `rename’: Permission denied -
jruby-complete.jar or lib/java/jruby-complete.jar (Errno::EACCES)

This is a fix for Rawr? I don’t see it in the Rawr changelog. If this is
for Rawr, where might I find it?

Yes. I created a new branch and pushed it per the kenai instructions.

Please push changes at the following SSH URL: ssh://
removed_email_address@domain.invalid/rawr~mainline


Best,
Marc

“Change requires small steps.”


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#15

I tried with jruby-1.2.0
The same problem.
It says: The system cannot find the path specified.
I installed on my laptop, first ruby, and after jruby, and for God sake,
I can’t mistake setting the path. …;C:\jruby-1.3.0\bin
Same answer.
So I lost any hope!
Adrian


#16

Hello,
No new ideas on what’s happening with my jruby -v?


#17

This problem happens on XP too. Windows is very persistent at holding on
to files, so you sometimes have to “coerce” it let go.

and by coerce I’ve had to use Sys Internals process explorer to kill
handles… or just reboot the computer :stuck_out_tongue:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email