Windows Glimmer DSL for libui: some samples failing in VSCode SOLVED

This is just a heads up on a Glimmer problem I experienced today. I am a very intermittent ruby programmer (long retired), and usually only program during the winter. I run windows 10 21H1, use VSCode 0.40.4 I and had Ruby 2.5 installed.

 I installed the Glimmer Gem and copied the examples directory to my coding directory so I could annotate the code without changing the original files.  In VSCode I was creating a launch.json to run each sample and started running in to problems running some of the samples.   Thinking I may be using an outdated Ruby versuin I installed newest version Ruby 3.1.1,p18 and the Glimmer gem and carried on.  Eventually I found my initial problems were due to missing directories one level up from the examples directory.   

Decided to continue on Ruby 3.1. and created my launch.json for all the example files. I did however still have several examples that blew up. I found 3 similar examples such as midi_player.rb, midi_player2.rb, midi_player3.rb, only one would fail (in this case midi_player.rb) and the rest work.
Found failed usually when the window was instantiated so assumed it was a code problem and different incorrect values for the parameters were being passed for windows instantiation.

Eventually while debugging I noticed that the errors were being reported by ruby-debug-ide version 2.5. Installed the 3.1 version of the gem and all my problems disappeared. Since VSCode did not find the gem file ruby-debug-ide.rb in the 3.1 directory it picked it up from the 2.5 directory.
Probably If I had not ran all files in debug mode while creating the launch.json I would have not had failures but later when debugging would have been scratching my head