Win XP & One-Click installer .dump problems

Hey,

I ran into an annoying bug while trying to use the Ferret gem:

C:\Documents and Settings\Ilya>ruby -v
ruby 1.8.4 (2006-04-14) [i386-mswin32]

C:\Documents and Settings\Ilya>gem list --local

*** LOCAL GEMS ***

ferret (0.10.6)
Ruby indexing library.

C:\Documents and Settings\Ilya>irb
irb(main):001:0> “\t\tabcd”.dump
=> “”\t\tabcd""
irb(main):002:0> require ‘ferret’
=> true
irb(main):003:0> “\t\tabcd”.dump
=> “” abcd"\000\000"
irb(main):004:0>

Something breaks in ruby after I include ferret and rails collapses on
the spot. The templating engine falls down and starts complaining about
weird characters in my .rhtml files.

More info on this and similar issues:
http://www.ruby-forum.com/topic/82204#new
http://rubyforge.org/tracker/?func=detail&aid=3837&group_id=12&atid=133

I’ve tried this on two different computers, with 1.8.4.20, 1.8.5… and
even 1.8.2, all yielding the same results. (Yes, I also tried different
versions of the ferret gem). Any suggestions?

Cheers,
Ilya

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs