Will Rails 2.0 support my 1.2 rails codes

Hello,

I am working with rails 1.2, since many books are available for this. I
am also learning few new things with rails 2.0 also.

I am just confused with this question.

Can i deploy my 1.2 codes on the rails 2.0 framework. I do not know what
happens sine i have not yet updated my gens with Rails 2.0.2. Will i be
able to work with my existing codes, if i update my gems with rails
2.0.2.

Pl. guide me…

Thanks

Yeah, you should be fine.

If your code calls for 1.2, then it must have the 1.2 gems installed.
That’s all.

They don’t “conflict” terribly much, although installing 2.02 means
you actually change some of the dependencies for 1.2, so you’ll have
to change the boot.rb file so it no longer uses require_gem ~~~~~ and
instead uses gem ~~~~~

Hope that helps.

Julian.

Learn Ruby on Rails! Check out the FREE VIDS (for a limited time)
VIDEO #4 coming soon!
http://sensei.zenunit.com/

By and large the answer is yes. Do make sure however that you have
squashed any deprecation warnings. You may also have to install
plugins for functionality that was extracted from core
(classic_pagination, acts_as_list etc…), and also check that any
plugins you are using also work on 2.0.

Fred

and a final word about installing Rails 2.0: It will NOT remove 1.2 :wink:
They will co-exist (wih gems, old versions always stay in the system
until explicitly uninstalled)

And if you don’t change RAI’L_GEM_VERSION in your environment.rb file,
your project will continue to use 1.2

So essentially, just install 2.0, see if it works, if not, see if you
can fix it without too much trouble. if not, set back the version to
1.2 (i assume its a “play around app” to learn struff?) and start your
next project directly on 2.0

On 15 Apr., 09:00, Frederick C. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs