Why i was not able to create rails application?

Dear Friends,

I have installed ruby 1.8.7 binary version in my windows machine. Then i
have installed rails2.3.4 and mysql 2.8.1 gems. Ruby gems version is
1.3.6. I have installed related dlls in my machine.

I was able to run ruby application successfully but when try create a
rails application by giving the command

rails sample

I received the following error
c:/ruby/lib/ruby/1.8/securerandom.rb:74:in random_bytes': No random device (NotImplementedError) from c:/ruby/lib/ruby/1.8/securerandom.rb:91:inhex’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/…/lib/rails_generator/generators/applications/app/app_generator.rb:195:in
create_initializer_files' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/../lib/rails_generator/generators/applications/app/app_generator.rb:129:increate_config_files’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/…/lib/rails_generator/generators/applications/app/app_generator.rb:32:in
manifest' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/../lib/rails_generator/base.rb:163:inrecord’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/…/lib/rails_generator/manifest.rb:21:in
initialize' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/../lib/rails_generator/base.rb:163:innew’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/…/lib/rails_generator/base.rb:163:in
record' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/../lib/rails_generator/generators/applications/app/app_generator.rb:28:inmanifest’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/…/lib/rails_generator/commands.rb:42:in
invoke!' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/../lib/rails_generator/scripts/../scripts.rb:31:inrun’
from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.4/bin/rails:18
from c:/ruby/bin/rails:19:in `load’
from c:/ruby/bin/rails:19

I dont know why its showing this error. could anyone help me to fix this
error.

Thanks in advance

Regards,
Jose martin

I don’t have a clue. Sorry.

You should probably ask this question on general Rails group, not I18n
Rails. Anyway, have you tried Rails 2.3.5?

Try Linux.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs