Why am I getting this, *** longjmp causes uninitialized stack frame ***: ruby terminated

*** longjmp causes uninitialized stack frame ***: ruby terminated
======= Backtrace: =========
/lib/i386-linux-gnu/libc.so.6(__fortify_fail+0x45)[0xb7499eb5]
/lib/i386-linux-gnu/libc.so.6(+0x104e0a)[0xb7499e0a]
/lib/i386-linux-gnu/libc.so.6(__longjmp_chk+0x4b)[0xb7499d7b]
/usr/lib/i386-linux-gnu/libcurl.so.4(+0xa325)[0xb6b80325]
[0xb777f40c]
[0xb777f416]
/lib/i386-linux-gnu/libc.so.6(__select+0x61)[0xb747dbd1]
/home/ubuntu/.rvm/gems/ruby-1.9.3-p448/gems/eventmachine-1.0.3/lib/rubyeventmachine.so(+0x113cc)[0xb6db63cc]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(rb_thread_blocking_region+0x127)[0xb76d0997]
/home/ubuntu/.rvm/gems/ruby-1.9.3-p448/gems/eventmachine-1.0.3/lib/rubyeventmachine.so(_ZN12SelectData_t7_SelectEv+0x3c)[0xb6db776c]
/home/ubuntu/.rvm/gems/ruby-1.9.3-p448/gems/eventmachine-1.0.3/lib/rubyeventmachine.so(_ZN14EventMachine_t14_RunSelectOnceEv+0x1b4)[0xb6db7b14]
/home/ubuntu/.rvm/gems/ruby-1.9.3-p448/gems/eventmachine-1.0.3/lib/rubyeventmachine.so(_ZN14EventMachine_t8_RunOnceEv+0x34)[0xb6db8d34]
/home/ubuntu/.rvm/gems/ruby-1.9.3-p448/gems/eventmachine-1.0.3/lib/rubyeventmachine.so(_ZN14EventMachine_t3RunEv+0x60)[0xb6dbac40]
/home/ubuntu/.rvm/gems/ruby-1.9.3-p448/gems/eventmachine-1.0.3/lib/rubyeventmachine.so(evma_run_machine+0x2b)[0xb6daf91b]
/home/ubuntu/.rvm/gems/ruby-1.9.3-p448/gems/eventmachine-1.0.3/lib/rubyeventmachine.so(+0xe6c4)[0xb6db36c4]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(+0x16cbdd)[0xb76b1bdd]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(+0x17b937)[0xb76c0937]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(+0x17200f)[0xb76b700f]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(+0x17763c)[0xb76bc63c]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(+0x178769)[0xb76bd769]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(rb_proc_call+0x57)[0xb75a2eb7]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(+0x56a64)[0xb759ba64]
/home/ubuntu/.rvm/rubies/ruby-1.9.3-p448/bin/…/lib/libruby.so.1.9(rb_exec_end_proc+0x1ee)[0xb759e2be]


This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs