Which version of Ubuntu to use with Rails


#1

Hello,

This is a question for folks who are using Ubuntu to host your Rails
apps. Which version of Ubuntu do you use?

Do you use the ‘Dapper’ release (6.0.6) perhaps due to the long term
support (LTS), or are you using the latest release ‘Feisty’ (7.0.4)?

Or maybe a better way to ask the question is, is there a preferred
version of Ubuntu to use with Ruby and Rails?

Thanks,
denisa


#2

I use Dapper, only because slicehost’s installer has that version.
Dapper can install everything you need to run rails, but the ease of
it depends on your chosen deployment stack. Dapper’s apt sources
doesn’t include apache 2.2 which you’ll need for proxying to mongrel,
so that has to be built from source. I’m pretty sure Feisty has apache
2.2 as a packaged installer.

deprec (gem install deprec) can build apache for you on Dapper, and it
works well.

–Andrew V.


#3

Hi,

It all depends on your deployment variant.
I developed on 6.10, now developing on 7.04, and the server is running
Debian 4.0.
My deployment solution is pound + mongrel_cluster.

Cheers,
Yuri

On 5/9/07, werdnativ removed_email_address@domain.invalid wrote:

support (LTS), or are you using the latest release ‘Feisty’ (7.0.4)?

Or maybe a better way to ask the question is, is there a preferred
version of Ubuntu to use with Ruby and Rails?

Thanks,
denisa


Best regards,
Yuri L.


#4

AFAIK Feisty is the first version to include Apache 2.2 under ‘apt’
control. You need 2.2 to do load balancing properly with mongrel.


#5

I’ve been using 6.06 with Rails since it came out, and it works fine
once you get all the bits installed. I can’t recall the exact
details, but there was some messing around with packages in order to
get everything installed correctly. It didn’t take long to resolve,
but it wasn’t as simple as it could have been.

I’ve got a 7.04 box that I’ll move to when I get around to it.

Either way, I don’t think you’ll have problems with Ubuntu and Rails.

Regards

Dave M.


#6

On 5/9/07, Neil W. removed_email_address@domain.invalid wrote:

AFAIK Feisty is the first version to include Apache 2.2 under ‘apt’
control. You need 2.2 to do load balancing properly with mongrel.

There are plenty of Apache alternatives for load balancing. I’ve had
good success with nginx and pound specifically:

http://nginx.net/

http://www.apsis.ch/pound/


Greg D.
http://destiney.com/