Where can I get gr-air-modes for GNUradio 3.6.5

Hi,

I try to install gr-air-modes from the git source, but it seems the code
only works with GNUradio 3.7. May I know where can I find the old
version
which is compatible with GNUradio 3.6.5?

Thanks.

Best regards,
Cheng C.

Hi,

I just pushed a tag called “3.6” representing the last commit of
gr-air-modes which was 3.6-compatible. Please note that a lot of the
newer
features of gr-air-modes are unavailable in this version. To use this
version, do a “git remote update” from the gr-air-modes folder, then
“git
checkout 3.6”.

Best,
Nick

At the moment I am looking at DME signals, still considering if it may
be possible to get smth. useful out of them.are you already through
these considerations? J

Ralph.

From: [email protected]lid
[mailto:[email protected]lid] On Behalf Of
Nick F.
Sent: Friday, 10 January, 2014 22:33
To: Cheng C.
Cc: GNURadio D.ion List
Subject: Re: [Discuss-gnuradio] Where can I get gr-air-modes for
GNUradio 3.6.5

Hi,

I just pushed a tag called “3.6” representing the last commit of
gr-air-modes which was 3.6-compatible. Please note that a lot of the
newer features of gr-air-modes are unavailable in this version. To use
this version, do a “git remote update” from the gr-air-modes folder,
then “git checkout 3.6”.

Best,

Nick

On Thu, Jan 9, 2014 at 7:34 PM, Cheng C. [email protected] wrote:

Hi,

I try to install gr-air-modes from the git source, but it seems the code
only works with GNUradio 3.7. May I know where can I find the old
version which is compatible with GNUradio 3.6.5?

Thanks.

Best regards,
Cheng C.

Hi Nick,

Thanks. It works fine.

I’ve another question. When using the modes_rx program, is there any
option
that I can specify to save the original sampled baseband data?

Best regards,
Cheng C.

Hello,

I use an external rubidium reference clock with my N210, everything
works fine with some patchs (python & c++ libs), but I failed with the
conventional way.

I found useful information on this page :
http://files.ettus.com/uhd_docs/manual/html/gpsdo.html
But this command below change nothing :confused:
sudo ./usrp_burn_mb_eeprom --args addr=192… --key=gpsdo
–val=external

Clock led remains off and the signal sampled is not locked (using for
exemple uhd_rx_cfile, uhd_fft.mod or osmocom_fft)

I solved my problem by patching my python scripts and the osmocom
library, but I wanted to know if I missed something somewhere.

For information, the line added to uhd_rx_cfile : (after the antenna
selection code)
self._u.set_clock_config(uhd.clock_config.external(), 0)

And for osmocom lib : (uhd_source_c.cc, end of the constructor)
_src->set_clock_source(“external”, 0);

Version used :
FW image : 003.006.002-rc2
linux; GNU C++ version 4.8.1; Boost_105300;
UHD_003.006.002-64-g92b0b7ab

Any feedback appreciated.

Good day, Guenael

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs