When starting rails 2.0.2 i get the following error


#1

I believe that my issue is releated to ticket
http://dev.rails-engines.org/ticket/285

Has there been any headway on this particular issue?

Error message.
/Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/active_support/
core_ext/module/aliasing.rb:31:in alias_method': undefined methodinitialize_schema_migrations_table’ for module
ActiveRecord::ConnectionAdapters::SchemaStatements' (NameError) from /Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/ active_support/core_ext/module/aliasing.rb:31:inalias_method_chain’
from /Users/kevin/Projects/time_tracking/vendor/plugins/
engines/lib/engines/rails_extensions/migrations.rb:131:in included' from /Users/kevin/Projects/time_tracking/vendor/plugins/ engines/lib/engines/rails_extensions/migrations.rb:131:inclass_eval’
from /Users/kevin/Projects/time_tracking/vendor/plugins/
engines/lib/engines/rails_extensions/migrations.rb:131:in included' from /Users/kevin/Projects/time_tracking/vendor/plugins/ engines/lib/engines/rails_extensions/migrations.rb:155:ininclude’
from /Users/kevin/Projects/time_tracking/vendor/plugins/
engines/lib/engines/rails_extensions/migrations.rb:155
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/
usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in gem_original_require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/ usr/lib/ruby/1.8/rubygems/custom_require.rb:27:inrequire’
… 47 levels…
from /Library/Ruby/Gems/1.8/gems/rails-2.0.2/lib/commands/
server.rb:39
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/
usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in gem_original_require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/ usr/lib/ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from ./script/server:3


#2

This bug was fixed in the trunk version of the engines plugin a few days
back:

http://dev.rails-engines.org/changeset/681

If you’re tracking edge rails, you’ll also need to stay use the trunk
version of the plugin, available from SVN or github:

http://svn.rails-engines.org/engines/trunk
git://github.com/lazyatom/engines.git

HTH,

James

On Thu, Apr 24, 2008 at 2:28 PM, Kevin Pratt


#3

Hi Kevin,

On Apr 24, 2008, at 8:28 AM, Kevin Pratt wrote:

I believe that my issue is releated to ticket http://dev.rails-engines.org/ticket/285

Has there been any headway on this particular issue?

Which version of engines are you using? If you’re using Rails 2.0.x,
you need to be using engines from the rb_2.0 branch. You can’t use
the trunk version after r681.

Rhett


#4

Thanks for your help guys.

Got that running both on the edge rails as well as the 2.0.2 gem.

Now, the reason I was trying to get it installed was I wanted to use
date_box engine.

Is this the right list to be asking questions about that particular
engine?

I keep getting the error

undefined method `config’ for DateboxEngine:Module

Anyone have any ideas?


#5

Thanks for the response.

This is exactly what I was wondering. “Does this plugin work with
rails 2.0”. Since it does not seem to I’ll dig around and see if I
can get it working.

Thanks for the help.

Kevin


#6

The ‘config’ method of setting defaults was removed as part of the 2.0
upgrade - it sounds like this plugin has not been updated to reflect
this.

To get around it, you might be able to extract the config
functionality out of an older version of the engines plugin (have a
look through some of the 1.1.x tags on http://svn.rails-engines.org/),
but that’s still no guarantee that this plugin plays well with Rails
2.0, alas.

HTH,

James

On Thu, Apr 24, 2008 at 7:33 PM, Kevin Pratt


#7

Which version of engines are you using? If you’re using Rails 2.0.x,
you need to be using engines from the rb_2.0 branch. You can’t use
the trunk version after r681.

Rhett

Thanks for the answer, you saved me from not making a deadline.
Although, you also validated my procrastination; I don’t know whether to
kiss you or punch you…

smooches