What versions go where

I am trying to track, what gems go to what version of ruby to what
rails. it is a bit of a chore. as i upgrade my ruby and rails, and
then watch the gems break.

for example, when it comes to authentication, restful and acts now give
me an error that i have not resolved yet. the error is:

The name ‘User’ is reserved by Ruby on Rails.
Please choose an alternative and run this generator again.

The user controller was not generated.
I have not yet found documentation for this.
What to do. What to do.

Do I just make a controller with a different name?

How is everybody else tracking, what, is where, and how, by version, for
an application?

And,

does Capistrano update gems to my hosted unix server from my local
development environment.

Any tips appreciated.

thanks

On Dec 4, 12:43 pm, “gemblon (t.b.)” <rails-mailing-l…@andreas-
s.net> wrote:

The user controller was not generated.
does Capistrano update gems to my hosted unix server from my local
development environment.

Any tips appreciated.

thanks

Posted viahttp://www.ruby-forum.com/.

Good question. I haven’t seen anything comprehensive, there’s a basic
table for the rails components thru rails 1.2: pack, record, mailer,
etc

http://wiki.rubyonrails.com/rails/pages/HowtoLockToSpecificRailsVersions

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs