What Version?

I am kinda new to ruby and new to ruby on rails. I originally had
1.9.1 installed but that caused errors when trying to install gems and
compile them. I then installed 1.8.6 and then that has errors when
trying to use postgresql. What version is the best to install on a
windows machine where gems install and work and databases seem to work
correctly? I am running Windows 7. Is there a huge difference between
1.9.1 and 1.8.7 and 1.8.6? Its kinda confusing for a person new to
rails and ruby. I am still teaching myself ruby so maybe i should just
grab the best version for that then worry about rails.
Thanks,
–Nick

On 3/13/2010 5:23 PM, Nick H. wrote:

–Nick

I use 1.9.1 on my Windows 7 install without problem. Make sure to use
the installer from http://rubyinstaller.org/. If you want to install
gems you’ll probably also want to download and install the devkit from
the same page (it’s very simple). I recommend 1.9 for new projects as
thats the newest version and 1.8.7 will eventually fall out of support.
Depending on what libraries you need you may have to go to 1.8.7 though,
as some still have not been updated for 1.9.

Good luck!

Nick H. wrote:

I am kinda new to ruby and new to ruby on rails. I originally had
1.9.1 installed but that caused errors when trying to install gems and
compile them. I then installed 1.8.6 and then that has errors when
trying to use postgresql. What version is the best to install on a
windows machine where gems install and work and databases seem to work
correctly? I am running Windows 7. Is there a huge difference between
1.9.1 and 1.8.7 and 1.8.6? Its kinda confusing for a person new to
rails and ruby. I am still teaching myself ruby so maybe i should just
grab the best version for that then worry about rails.

I’d suggest 1.8.7, since the vast majority of 1.8.6 code runs happily
under 1.8.7, and 1.8.7 is the minimum which will be required for Rails
3.

By staying away from 1.9 you’ll avoid a lot of headaches from libraries
which have not been modified to be 1.9-compatible - and 1.9 is still
changing anyway. That’s unless you want to be involved in the
development and testing of those libraries.

One day, the situation may be reversed.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs