What version of Rails/Ruby to use

Hello all,

I’m running into a quagmire of RoR and Rails versions, and I’d like
some advice on what to use.

I’d like to set up a RoR environment where I can find ample examples
and possibly a couple of good books to help me along, but I’m not sure
which version(s) to use: Should I go for RoR 2.1, and if so, do I use
Ruby 1.9 (cutting edge option) or should I stay with RoR 1.2 and an
older version of Ruby?

I’m a big fan of the Pragmatic Bookshelf books, but both ‘cutting edge
version’ books (the pickaxe and the Agile Development with RoR) seem
to be in Beta.

Also, if I do choose older versions of RoR/Ruby, has anyone got any
experience with upgrading from these to newer versions? Will it be
prohibitively difficult?

Any advice/tips are appreciated.

Cheers,

Alex.

On Wed, Aug 20, 2008 at 7:20 AM, SnakeNuts [email protected]
wrote:

older version of Ruby?
I would stick with Ruby 1.8.x. 1.9 is still in development. Rails 2.1
is
the only version that is compatible with Ruby 1.8.7, otherwise you’ll
need
1.8.6 for any version of Rails prior to 2.1.

Rails 2.1 has some compelling features (Timezones, Named scopes), so I
would
highly recommend it.

I’m a big fan of the Pragmatic Bookshelf books, but both ‘cutting edge
version’ books (the pickaxe and the Agile Development with RoR) seem
to be in Beta.

Also, if I do choose older versions of RoR/Ruby, has anyone got any
experience with upgrading from these to newer versions? Will it be
prohibitively difficult?

It’s a good time! You’ll want to update one version at a time, and fix
any
errors or deprecation warnings that come up. If you have a good test
suite,
this is pretty easy. If not, godspeed. :wink:

So, if you have an app that is on 1.0.x, update it to 1.1.x, fix any
errors
or warnings, then rinse and repeat with 1.2.x, 2.0.x, and 2.1.

Any advice/tips are appreciated.

Cheers,

Alex.

Brandon


Sessions by Collective Idea: Ruby on Rails training in a vacation
setting
http://sessions.collectiveidea.com

I’m working with Ruby 1.8 and Rails 2.0.2… no major issues.

They call it the “bleeding edge” for a reason…

On Aug 20, 3:28 pm, Ar Chron [email protected] wrote:

I’m working with Ruby 1.8 and Rails 2.0.2… no major issues.

They call it the “bleeding edge” for a reason…

Indeed :slight_smile:

Thanks for the help guys. I just don’t want to get going with RoR and
then find out the version I’m using is defunct/deprecated/buggy/etc…

I’ll try my luck with 2.1 and 1.8.7. I think I can stand a little
‘bleed’ :slight_smile:

Alex.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs