What is easies gui to install ? - tk, gtk, fxruby etc

What is the easiest gui to install and use with ruby such as tk, gtk,
fxruby,qtruby, etc ?

There is all kinds of builds and stuff to figure out it seems … the
easier the better … a few yum installs and gem install would be
nice …

I have centos 5 64 bit

thanks

You can install qtruby by making sure you have qt4 installed, and then
‘gem install qtbindings’.

It’s pretty easy.

Snow Leopard on a Mac! Even if you’re totally blind you can do it
because if you fail to respond to the screen, your computer starts
talking to you. Windows can’t do that with any version and I doubt
Microsoft will manage to do it during my lifetime. The G.U.I. with the
fewest questions has to be Ubuntu with its ubiquity installer once orca
comes up and only 7 steps to a basic install.

On Oct 5, 1:10 pm, Steve K. [email protected] wrote:

You can install qtruby by making sure you have qt4 installed, and then
‘gem install qtbindings’.

It’s pretty easy.

This is as far as I got … thanks

yum install qt4
yum install cmake

yum install qt4-devel

export PATH=$PATH:/usr/lib64/qt4/bin/
gem install qtbindings

Build files have been written to: /usr/lib64/ruby/gems/1.8/gems/
qtbindings-4.6.3.0/ext/build
cd ext/build; make
make[1]: Entering directory /usr/lib64/ruby/gems/1.8/gems/ qtbindings-4.6.3.0/ext/build' make[2]: Entering directory/usr/lib64/ruby/gems/1.8/gems/
qtbindings-4.6.3.0/ext/build’
make[3]: Entering directory /usr/lib64/ruby/gems/1.8/gems/ qtbindings-4.6.3.0/ext/build' Scanning dependencies of target cppparser make[3]: Leaving directory/usr/lib64/ruby/gems/1.8/gems/
qtbindings-4.6.3.0/ext/build’
make[3]: Entering directory /usr/lib64/ruby/gems/1.8/gems/ qtbindings-4.6.3.0/ext/build' [ 1%] Building CXX object generator/parser/CMakeFiles/cppparser.dir/ ast.o [ 2%] Building CXX object generator/parser/CMakeFiles/cppparser.dir/ default_visitor.o [ 3%] Building CXX object generator/parser/CMakeFiles/cppparser.dir/ memorypool.o [ 3%] Building CXX object generator/parser/CMakeFiles/cppparser.dir/ visitor.o [ 4%] Building CXX object generator/parser/CMakeFiles/cppparser.dir/ control.o [ 5%] Building CXX object generator/parser/CMakeFiles/cppparser.dir/ lexer.o /usr/lib64/ruby/gems/1.8/gems/qtbindings-4.6.3.0/ext/generator/parser/ kdevvarlengtharray.h:60: error: expected constructor, destructor, or type conversion before ‘typedef’ /usr/lib64/ruby/gems/1.8/gems/qtbindings-4.6.3.0/ext/generator/parser/ lexer.cpp:32: error: expected constructor, destructor, or type conversion before ‘void’ make[3]: *** [generator/parser/CMakeFiles/cppparser.dir/lexer.o] Error 1 make[3]: Leaving directory/usr/lib64/ruby/gems/1.8/gems/
qtbindings-4.6.3.0/ext/build’
make[2]: *** [generator/parser/CMakeFiles/cppparser.dir/all] Error 2
make[2]: Leaving directory /usr/lib64/ruby/gems/1.8/gems/ qtbindings-4.6.3.0/ext/build' make[1]: *** [all] Error 2 make[1]: Leaving directory/usr/lib64/ruby/gems/1.8/gems/
qtbindings-4.6.3.0/ext/build’
make: *** [build] Error 2

Gem files will remain installed in /usr/lib64/ruby/gems/1.8/gems/
qtbindings-4.6.3.0 for inspection.
Results logged to /usr/lib64/ruby/gems/1.8/gems/qtbindings-4.6.3.0/
gem_make.out

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs