What does this error mean `activate': can't activate activesupport (= 3.0.1, runtime) for

i am using active record in my program and cannot understand what this
error means.

require ‘watir’

include Watir
require ‘active_record’

ActiveRecord::Base.establish_connection(
:adapter => “mysql”,
:host => “127.0.0.1”,
#:host => “sun”,
:database => “Trader”,
:username => “root”,
:password => “password”
)
class Rawdata < ActiveRecord::Base
set_table_name “rawdatas”

end

E:\TradingTools\trader\app\helpers>GrabMBTTrades.rb
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:233:in activate': can't activate activesupport (= 3.0.1, runtime) for ["activerecord-3.0.1"], already activated a ctivesupport-2.3.9 for ["firewatir-1.6.6", "watir-1.6.6"] (Gem::LoadError) from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:249:inactivate’
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:248:in
each' from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:248:inactivate’
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:35:in
`require’
from E:/TradingTools/trader/app/helpers/GrabMBTTrades.rb:8

On Oct 23, 11:37am, Junkone [email protected] wrote:

:host => “127.0.0.1”,
E:\TradingTools\trader\app\helpers>GrabMBTTrades.rb
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:233:in `activate’: can’t
activate
activesupport (= 3.0.1, runtime) for [“activerecord-3.0.1”], already
activated a
ctivesupport-2.3.9 for [“firewatir-1.6.6”, “watir-1.6.6”]
(Gem::LoadError)

It is telling you that firewater and watir required activesupport
2.3.9, so if you want ActiveSupport 3.0.1 you need to require it first
(before requiring watir)

In that case Watir will raise an exception because it strictly loads
2.3.9. There is plan to remove active-support dependency completely in
FireWatir

Jarmo

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs