Weird auto-complete production problem in Rails 2.3.2


#1

Hello.

ruby 1.8.6 (patchlevel 111)
rails 2.3.2
Windows XP Professional

I am getting quite a weird problem. I have several auto-complete
fields in a page. When I run the code in development mode everything
works but when the application runs in production mode one and only
one of the fields does not auto-complete anymore.

The database being used is the same in both cases (I’m just replacing
‘development:’ and ‘production:’ in database.yml whenever I change
environments) so a data problem is out of the question.

I have looked and compared code between different auto-complete fields
and everything is identical except for the field names. Controller
code does not seem to be a problem either. Checked logs and I can’t
see anything obviously wrong either. Searched the web but found
nothing.

Any help would be appreciated.

Thanks a lot.

Pepe


#2

Still trying to figure this out. Some more info:

The auto-complete field that does not work depends on the values
entered in 2 other auto-comple fields. In development the 2 fields are
being updated correctly but not when the application runs in
production mode mode.

Those values are stored in session variables and I have read that
there are changes as how sessions behave with 2.3.2. Any ideas what
might be going on?

Thanks a lot.


#3

Found a hack?

I looked into the environments folder and compared development vs.
production. I found this line:

config.action_controller.consider_all_requests_local = false

I changed it to ‘true’ and the application now works. Any kind soul
that could explain this to me? I’m not really a Rails expert.

Thanks


#4

Thanks for the explanation, but I was looking more towards of why the
application works after changing that setting, which should have
nothing to do about how sessions work, which I believe to be the real
problem.

I have noticed that when auto-complete fields are used and vaulues
selected the session variables I store those values in work fine and
contain data but when I change to production those session variables
are not being updated.

I am using one controller only, if that means anything.

Thanks.


#5

pepe wrote:

Found a hack?

I looked into the environments folder and compared development vs.
production. I found this line:

config.action_controller.consider_all_requests_local = false

I changed it to ‘true’ and the application now works. Any kind soul
that could explain this to me? I’m not really a Rails expert.

AWDWR(3rd), p 686 says:

The default setting of true means that all exceptions will display error
and backtrace information in the browser. Set this to false in
production to stop users from seeing this information.