WebServices: execution expired


#1

1 hour spent and I can’t got explanation why I have “execution expired”
when I trying to test this web service:

Pointed to: http://localhost:3000/news/list

class NewsService < ActionWebService::Base
web_service_api NewsApi

def list
[NewsTopic.new, NewsTopic.new]
end
end

class NewsController < ApplicationController
wsdl_service_name ‘news’

web_service_dispatching_mode :delegated
web_service :news, NewsService.new

def list
news = ActionWebService::Client::Soap.new(
NewsApi, “http://localhost:3000/news/news”)
rsp = news.list
render_text rsp.to_s
end
end

Strange, but I have successful log message:

Web Service Response (0.024314): => [#<NewsTopic:0xb7612328
@attributes={“last_modified”=>nil, “title”=>nil, “id”=>nil,
“contents”=>nil, “preview”=>nil, “sticky”=>nil}, @new_record=true>,
#<NewsTopic:0xb7612314 @attributes={“last_modified”=>nil, “title”=>nil,
“id”=>nil, “contents”=>nil, “preview”=>nil, “sticky”=>nil},
@new_record=true>]

<?xml version="1.0" encoding="UTF-8" ?>

<env:Envelope xmlns:xsd=“http://www.w3.org/2001/XMLSchema
xmlns:env=“http://schemas.xmlsoap.org/soap/envelope/
xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
env:Body
<n1:ListResponse xmlns:n1=“urn:ActionWebService”
env:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”>







<last_modified xsi:nil=“true”></last_modified>







<last_modified xsi:nil=“true”></last_modified>


</n1:ListResponse>
</env:Body>
</env:Envelope>
Sending data
Completed in 0.03303 (30 reqs/sec) | Rendering: 0.00013 (0%) | DB:
0.00762 (23%) | 200 OK [http://localhost/news/news]


#2

I am following the instruction on the wiki and when I run: gem install
login_generator

I get: Permission denied -
/usr/local/lib/ruby/gems/1.8/cache/login_generator-1.2.0.gem

How can fix this? Thanks in advance.

http://www.ProblemSolvingSkill.net
Hone your problem-solving skills


#3

I am following the instructions at http://rails-engines.org/ and I got
Cannot install using
subversion because `svn’ cannot be found in your PATH error message when
I ran script/plugin
install -x command. So I installed the Subversion and now I am getting
Cannot install using
externals because this project is not under subversion.

What are the pre-requisites to installing the login engine? Should I
install the Subversion client
on my machine? I am on Mac OS 10.4. Thanks in advance.

http://www.ProblemSolvingSkill.net
Hone your problem-solving skills


#4

Bala P. wrote:

I am following the instruction on the wiki and when I run: gem install login_generator

I get: Permission denied - /usr/local/lib/ruby/gems/1.8/cache/login_generator-1.2.0.gem

How can fix this? Thanks in advance.

By changing the permissions so that you can both read that file and that
directory. You also need to have execute permission on the directory.
Since this is a system directory, ultimately you will have to have root
privileges.

sudo gem install login_generator

is probably the magic incantation that you want.

Ray