WEBrick.. won't start and showing '/rails-2.0.2/lib/initializer.rb:159:in `require_frameworks': Cou

Hi
WEBric won’t strat and showing the following errors:-

=> Booting WEBrick…
/mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/
lib/initializer.rb:159:in `require_frameworks’: Could not find RubyGem
jruby-openssl (>= 0.0.0) (RuntimeError)

    from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/gems/1.8/gems/

rails-2.0.2/lib/initializer.rb:156:in process' from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/gems/1.8/gems/ rails-2.0.2/lib/initializer.rb:49:inrun’
from /mnt/slash/home/akumar/bookstore/config/environment.rb:
19:in run' from /mnt/slash/home/akumar/bookstore/config/environment.rb: 19:inrequire’
from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/site_ruby/1.8/
rubygems/custom_require.rb:27:in require' from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/gems/1.8/gems/ activesupport-2.0.2/lib/active_support/dependencies.rb:496:inrequire’
from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/gems/1.8/gems/
rails-2.0.2/lib/commands/servers/webrick.rb:59:in new_constants_in' from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/gems/1.8/gems/ activesupport-2.0.2/lib/active_support/dependencies.rb:496:inrequire’
… 7 levels…
from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/gems/1.8/gems/
rails-2.0.2/lib/commands/server.rb:38:in require' from /mnt/slash/home/akumar/jruby-1.1b1/lib/ruby/site_ruby/1.8/ rubygems/custom_require.rb:27:inrequire’
from script/server:3:in `require’

I am using the JRUBY 1.1bl and rails 2.0.2

Please install jruby-openssl gem.

gem install jruby-openssl

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs