Webrick won't boot, deprecation warning

I haven’t worked on my Rails project in a while and today I decided to
shake the dust off her and give her a go…

I did an svn up on my entire project which also updated the svn
external “rails” in RAILS_ROOT/vendor.

When I tried to start webrick, it spit out this message and died:
=> Booting WEBrick…
DEPRECATION WARNING: Reloadable::Subclasses has been deprecated and
has no effect. See http://www.rubyonrails.org/deprecation for
details. (called from /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.5/

Three questions:

  1. Why is it using actionpack in /usr/lib/ruby/gems/1.8/gems instead
    of RAILS_ROOT/vendor/rails?
  2. Why is webrick not booting?
  3. How do I update the stuff in RAILS_ROOT/script (which is a part of
    my svn project, but obviously not Rails)?

Thanks for the help.

P.S. One more question. How do I make an svn external checkout of
the latest stable version of Rails (I think currently mine is set to
Rail’s HEAD and I’m getting development versions)?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs