Webrick Timeout Problem


#1

I posted this to the ruby on rails google group, but this forum is
probably a better place to find the answer.

I’m going through the ‘how to make a blog in 15 minutes’ tutorial on my
ibook right now. I have mysql, ruby, and rails all setup, and the
tutorial was going smoothly until I tried to configure the database.yml
file. I create a mysql user and gave him privileges to the appropriate
tables, but now when i go to http://0.0.0.0:3000/blog, my browser just
stalls and keeps saying ‘Loading…’. I don’t get any usefull error
messages from the server. I changed the mysql password settings back
and forth between old and new, and that didn’t seem to help. When I
put a bad mysql user/password, I get a connection error, so this
problem only seems to be happening when I use a good u/p pair.

I have the following in my socket: /tmp/mysql.sock, and this seems to
be OK since it is able to generate errors when I enter a bad username
or password.

I checked the log/development.log file, and here are the last several
lines that result from me hitting refresh on the blog page 3 times:
Processing BlogController#index (for 127.0.0.1 at 2006-03-06 21:34:13)
[GET]
Parameters: {“action”=>“index”, “controller”=>“blog”}

Processing BlogController#index (for 127.0.0.1 at 2006-03-06 21:37:16)
[GET]
Parameters: {“action”=>“index”, “controller”=>“blog”}

Processing BlogController#index (for 127.0.0.1 at 2006-03-06 21:44:58)
[GET]
Parameters: {“action”=>“index”, “controller”=>“blog”}

So the app just seems to be freezing, without spitting out an error
message. Does anyone have any ideas what might be causing this problem
or how I could troubleshoot this to try to get a more usefull error
message?

Any help is greatly appreciated.

Kortina