Webrick 'require_frameworks' message

#1

Any ideas if this is a version or a config issue?
Runmning Gems 1.0.1, rails is 2.0.2
kenbob

ruby script/server
=> Booting WEBrick…
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
require_frameworks': no such file to load -- openssl (RuntimeError) from /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:88:inprocess’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:in send' from /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:inrun’
from /home/kenny/KensLib/myrails/Dec28/config/environment.rb:13
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:342:innew_constants_in’
… 7 levels…
from
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/server.rb:39
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

#2

On 28 Dec 2007, at 16:13, Ken Welborn wrote:

Any ideas if this is a version or a config issue?
Runmning Gems 1.0.1, rails is 2.0.2
kenbob

ruby script/server
=> Booting WEBrick…
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
`require_frameworks’: no such file to load – openssl (RuntimeError)

Do you have openssl installed (and openssl development headers so that
ruby can build its openssl extensions) ?

Fred

#3

Frederick C. wrote:

On 28 Dec 2007, at 16:13, Ken Welborn wrote:

Do you have openssl installed (and openssl development headers so that
ruby can build its openssl extensions) ?

I’m having the same problem one one of my servers but not all of them. I
don’t see what the difference is. But on my development box, Webrick
fails to start with the openssl exception. On the test box, it runs
fine. So, can you be specific about what files/libraries I can look for
to verify that openssl is installed with the development headers?

I followed the instructions at rubyonrails.org/down. There was no
mention there that openssl is an external requirement - I thought that
it came with ruby-1.8.6. I downloaded and compiled ruby-1.8.6 with
“./configure --prefix=/home/mdhender”. Checking the config logs, there’s
nothing about openssl. No warnings, no errors, no complaints. I just
don’t see what configure is looking for.

Mike

#4

On 28 Dec 2007, at 21:19, Michael Henderson wrote:

them. I
don’t see what the difference is. But on my development box, Webrick
fails to start with the openssl exception. On the test box, it runs
fine. So, can you be specific about what files/libraries I can look
for
to verify that openssl is installed with the development headers?

That rather depends on what operating system you’re on, but on my
machine I have a /usr/include/openssl/

I followed the instructions at rubyonrails.org/down. There was no
mention there that openssl is an external requirement - I thought that
it came with ruby-1.8.6. I downloaded and compiled ruby-1.8.6 with
“./configure --prefix=/home/mdhender”. Checking the config logs,
there’s
nothing about openssl. No warnings, no errors, no complaints. I just
don’t see what configure is looking for.

It is part of ruby 1.8.6. It’s not vital to ruby, so if it can’t do it
it just skips it.
To build it you cd to ruby_source/ext/openssl and run extconf.rb (and
then make; make install)
It should complain at this point if the openssl headers can’t be found

Fred

#5

On the test box (where Webrick works), I have

…/lib/ruby/1.8/openssl/
…/lib/ruby/1.8/openssl.rb

I am missing those on the development box. Poking around some more, I
found out that I am missing the openssl headers on the box. I did not
have the “/usr/include/openssl” directory. I did an apt-get libssl-dev,
reconfigured/compiled/installed ruby and now Webrick works as expected
on the development box.

I am still puzzled as to where the configure tests for the headers.

Mike

#6

I was having the same problem as you on Ubuntu. I found the answer so
hopefully others will find it here as well. You have to install this
package:

sudo apt-get install libopenssl-ruby

And the error should go away for you (it did for me on Slicehost).

Hope that helps.

Carl Anderson

#7

Michael Henderson wrote:

On the test box (where Webrick works), I have

…/lib/ruby/1.8/openssl/
…/lib/ruby/1.8/openssl.rb

I am missing those on the development box. Poking around some more, I
found out that I am missing the openssl headers on the box. I did not
have the “/usr/include/openssl” directory. I did an apt-get libssl-dev,
reconfigured/compiled/installed ruby and now Webrick works as expected
on the development box.

I am still puzzled as to where the configure tests for the headers.

Mike

Hi guys,

Today I did an “gem update rails -y” and immediately afterwards I am
having n number of issues. First Webrick was running, but the was not
responding currently.

When I cleared the old version of most of the gems, and did an
install/update again, it doesnt start the WEbrick anymore, giving this
message about “require_frameworks”.

I read your post and checked that I have /usr/include/openssl and the
other two directories as well (ones Mike found).

However, since I have not compiled my own copy of ruby, (I am on Ubuntu
and using their package for ruby 1.8.6) I am not sure how can I move
on…

Any ideas/suggestions please…

regards

#8

Carl wrote:

I was having the same problem as you on Ubuntu. I found the answer so
hopefully others will find it here as well. You have to install this
package:

sudo apt-get install libopenssl-ruby

And the error should go away for you (it did for me on Slicehost).

Hope that helps.

Carl Anderson

Hi,

I checked and found that I already have that package installed.

however, I still went ahead and reinstalled that package. Still no
change in behaviour. :frowning:

any more ideas.

regards
raghav…

#9

Do you have the ruby-dev packages installed?

On Feb 1, 11:50 pm, Try R. removed_email_address@domain.invalid

#10

I should clarify, do you have ruby1.8-dev package installed?

#11

Carl wrote:

I should clarify, do you have ruby1.8-dev package installed?

Hi,

As it turned out and I had forgotten in the meantime, that I did not
install ruby from the Ubuntu packages, rather from the site by compiling
it.

There was the source available on my system. Even then, I took the
latest patch level of ruby source and compiled on my system, things
worked fine afterwards.

thanks for everybody’s time and attention.

regards
raghav…

#12

I too occured the error but unable to resolve it till now.

I’m using RHEL4 and did a gem update rails -y.

Updated from gem 0.94 to 1.1.1, rails 1.2.5 to 2.0.2

I too have openssl 0.9.7a on my machine.

Any assistance? Thanks! = ]

#13

For those of you who struggled through the message boards to try and fix
this here is what fixed it for me. I am installing and running Ruby on
Rails for the first time and running through one of the online
tutorials. I am using Ubuntu and kept getting the error message of the
original post.

  1. “su” to become root and do “apt-get install libopenssl-ruby” to get
    all the whole library.
  2. To get the header files, still as root, do “apt-get install
    ruby1.8-dev” which gives the development headers.
  3. Now you can go to the “ruby_directory/ext/openssl” and run “ruby
    extconf.rb” and it should work with no problem. Then “run make”. Then
    “make install”.

I kept trying to go to the ext/openssl directory and run the “ruby
extconf.rb” and it kept telling me to go to hell!. Once you run those
two apt-get’s it should have everything you need to install openssl.

Oh to clarify on the directory “~/ruby-1.8.7-p72/ext/openssl$” so it is
just the latest ruby package installed to the home directory.

Hope that helps the new users!

#14

Carl wrote:

I was having the same problem as you on Ubuntu. I found the answer so
hopefully others will find it here as well. You have to install this
package:

sudo apt-get install libopenssl-ruby

And the error should go away for you (it did for me on Slicehost).

Hope that helps.

Carl Anderson

Yes this works for me thanks a lot…

#15

Sorry in step 3 that is just plain “make” not “run make”.

#16

This was helpful. I have Ubuntu 10.10 and I noticed that when I tried:
sudo apt-get install libopenssl-ruby1.8
I would get:

Note, selecting ‘libruby1.8’ instead of 'libopenssl-ruby1.8

I assume that libruby1.8 now includes libopenssl.

In addition, since I am using rvm, I had to remove and reinstall my
version of ruby before it would pick up the packages.
rvm remove ruby-1.8.7
rvm install ruby-1.8.7
Cheers.