WEBrick killed by Apple Security Update?

Hey everybody - just checking in to see if anybody has the same issue; I
just installed Apple’s latest Security Update this morning, and oddly,
when I run ./script/server to start WEBrick, it poops out and returns me
to the command prompt!

Last night, I also installed XCode Tools, but if I remember right,
everything was OK then…

Wait. Sorry for the false alarm. I just created an empty rails project
and ran server from that one and it worked ok. The problem isn’t with
WEBrick, just my project.

Sorry to cry wolf…

Aha! It was the Flex_Image plugin!

Somehow it was messing with WEBrick… strange…

Anybody else seen this?

Yea…I installed flex_image and now my Mongrel server won’t start up…

This is what I see from the Terminal Console:

=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs