Webrick for project won't start anymore

Hi,

I am not sure what I did. I really didn’t change anything, but… I
can’t get webrick to start anymore for my project. I can get it to start
on an old copy of the project…

I am fairly new to Ruby/Rails and ended up taking over this project when
our other developer left. I have been doing mainly maintenance on it
with some new development. I was changing one of the controllers where
we create a pdf, and basically all I had done was make it try to use a
different font in the pdf, and it ran the first couple times and then
wouldn’t run anymore. I removed my changes but it still will not boot
webrick for this project anymore.

I am using RadRails, here is the output from the console:

=> Booting WEBrick…
D:/Programs/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/webrick.rb:11:
warning: already initialized constant OPTIONS
=> Booting WEBrick…
D:/Programs/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/webrick.rb:11:
warning: already initialized constant OPTIONS
D:/Programs/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:249:in
load_missing_constant': Expected ./script/../config/../vendor/plugins/acts_as_attachment/lib/technoweenie/acts_as_attachment.rb to define Technoweenie::ActsAsAttachment (LoadError) from D:/Programs/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:452:inconst_missing’
from
./script/…/config/…/vendor/plugins/acts_as_attachment/init.rb:6:in
load_plugin' from D:/Programs/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:401:inload_plugin’
from
D:/Programs/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/core_ext/kernel/reporting.rb:11:in
silence_warnings' from D:/Programs/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:401:inload_plugin’
from
D:/Programs/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:185:in
load_plugins' from D:/Programs/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:185:ineach’
from
D:/Programs/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:185:in
load_plugins' ... 20 levels... from D:/Programs/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:inrequire’
from ./script/server:3
from -e:4:in `load’
from -e:4

Thanks for your help.
-JRM

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs