Webrick error after updating rails, gems 1.2.2, 0.9.2


#1

Any help is appreciated.

$ script/server webrick
=> Booting WEBrick…
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/dependencies.rb:263:in load_missing_constant': uninitialized constant ActiveSupport::Deprecation::RAILS_DEFAULT_LOGGER (NameError) from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/ active_support/dependencies.rb:452:inconst_missing’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/deprecation.rb:16
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/deprecation.rb:23:in warn' from /usr/local/lib/ruby/gems/1.8/gems/actionmailer-1.3.2/lib/ action_mailer/base.rb:374:inserver_settings=’
from script/…/config/…/config/environments/development.rb:
23:in load_environment' from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/ initializer.rb:204:inload_environment’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/core_ext/kernel/reporting.rb:11:in silence_warnings' from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/ initializer.rb:201:inload_environment’
… 11 levels…
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/dependencies.rb:495:in require' from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/ commands/server.rb:39 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’
from script/server:3


#2

Hey Joe,

Looks like something old is hanging around in your development.rb

Did you run “rake rails:update” to get your app configed for 1.2.2?

Jodi


#3

Yep, even updated environment.rb to point to 1.2.2.

Joe


#4

That was it, good eye, Tex.


#5

I’d then start ripping out non standard configs -

  • the trace runs right through action_mailer - are you configuring
    that in environment?

ActionMailer could be a red herring, but that trace should reveal the
problem(or hindsight symptoms).

Jodi