Webgen 0.4.5


#1

Hey everybody!

I just release a new webgen version which fixes some bugs and brings
one new feature: customizable links to any file handled by webgen.
Have a look at http://webgen.rubyforge.org/news.html to see a
complete list of changes!

Best regards,
Thomas

What’s webgen?

webgen is a tool to generate static websites by combining content
with template files. You create one or more template files in which
you define the layout of your page and where the content should go.
After that you create page files in which you only define the
content. You can use a variety of markup languages like Textile or
Markdown to define your content and you can add dynamic parts via ERB
or by using webgen tags. This allows the automatic generation of
menus, breadcrumb trails and much more!

Have a look at the examples page at http://webgen.rubyforge.org/
examples/index.html to get a first impression of webgen!


#2

Hi, Thomas

Thomas L. wrote:

Hey everybody!

I just release a new webgen version which fixes some bugs and brings one

that’s good news :slight_smile:
i wanted to install the new version immediately,
but with =

C:\WINNT\system32>ruby -v
ruby 1.8.5 (2006-08-25) [i386-mswin32]

it gave me =

C:\WINNT\system32>gem install webgen
ERROR: While executing gem … (Zlib::BufError)
buffer error

Regards, Gilbert


#3

On Jun 29, 2007, at 1:40 PM, Gilbert R. wrote:

i wanted to install the new version immediately,

Regards, Gilbert

Jamis B. may have the solution on his recent post about Capistrano
2.0RC4

http://weblog.rubyonrails.com/2007/6/29/capistrano-2-0-preview-4

ensure
zis.finish if zis
end
That seems to do the trick for me; let me know if it doesn’t work
for you.
Might be worth a try. (Of course, you could just get a Mac, too :wink:

-Rob

Rob B.
removed_email_address@domain.invalid
http://agileconsultingllc.com


#4

Thomas L. wrote:

Hi,

I tried it out on Windows XP with the One-Click-Installer, failed for
me, too. However, after updating Rubygems from 0.9.2 to 0.9.4 it worked
for me. So try a:

gem install rubygems_update
update_rubygems
gem install -y webgen

ruby -v
ruby 1.8.5 (2006-08-25) [i386-mswin32]

gem -v
0.9.0

updating gem worked only with =
gem update --system

now it’s 0.9.4
and gem install webgen worked :slight_smile:

Gilbert


#5

Hi,

I tried it out on Windows XP with the One-Click-Installer, failed for
me, too. However, after updating Rubygems from 0.9.2 to 0.9.4 it
worked for me. So try a:

gem install rubygems_update
update_rubygems
gem install -y webgen

hth,
Thomas

ps. Ruby 1.8.6 on Windows installed using One-Click-Installer has a
bug which prevents webgen from working correctly, so stay with the
1.8.5 version till the next release of 1.8.6 (bug has already been
fixed)