WBX: Failed to set center frequency

Hello,

I’m doing some spectrum sensing with the WBX and the USRP2, I’m using
the usrp_spectrum_sense script. I do my scans over the whole range of
the WBX, from 50 MHz to 2.2GHz. When I do a scan, sometimes I’ll get
an error message “Failed to set center frequency: FFF” At first, I
thought I had either my tune_delay or dwell_delay value set too low.
I tried increasing both incrementally to 500ms each. This helped a
little, but there are certainly still failures.

Usually it will fail 0-8 times per scan. I’ve noticed to that a lot
of the same frequencies will fail, but it’s never consistent.

I’ve also noticed some unexplained peaks that occur near the
frequencies that fail. There are certainly more of these peaks when I
have more failures. So far, I’ve been testing in a controlled
envoironment with either the input terminated or using a tone
generated by a signal generator.

Has anyone else run into this problem? I don’t think it could be the
tune/dwell delays, 500ms is really high delay time. Is there an
optimal tune/dwell delay for the WBX? No values I’ve tried have fully
solved my problem though. Could either the tune/dwell delay times be
frequency dependent?

Thanks For Any Help,
Devin

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs