Watir is unable to click Facebook "Login" button after button.click is executed

Hi,

I tried to use Watir & ruby & IE9 to automate Facebook login but seems
the “Login” button is protected by Facebook.
Below is my code snip:

ie = IE.new
ie.goto(‘http://www.facebook.com/login.php’)
ie.text_field(:id, ‘email’).value = @user
ie.text_field(:id, ‘pass’).value = @pass
ie.button(:name, ‘login’).click
puts ‘*** debug string here ***’

When this code snip is executed, IE is opened and go to the login page,
then the fields are filled. But the login button is not clicked. IE
still displays the login page without being submitted.
In the console, ‘*** debug string here ***’ is printed directly. No
error occurs.

The same code in Google search page works fine.

ie.text_field(:name, ‘q’).value = ‘watir’
ie.button(:name, ‘btnG’).click

Does anyone encountered the same situation like me or anyone could give
me any advice?

Regards,
Alex

I don’t know anything about watir, but I tried with mechanize a while
ago and it worked fine. Here is my code for fb login;

require ‘mechanize’

def fb_login
agent = Mechanize.new
page = agent.get(‘http://www.facebook.com’)
form = page.forms.first
form.field_with(:name => ‘pass’).value = ‘user’
form.field_with(:name => ‘email’).value = ‘pass’
result = agent.submit(form)
agent
end


http://blog.eugen.co

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs