Watir gem update error


#1

When trying to complete a gem update this is what I am seeing:

gem update

Upgrading installed gems…
Attempting remote upgrade of watir
Attempting remote installation of ‘watir’
ERROR: While executing gem … (OpenURI::HTTPError)
404 Not Found

What does this mean and how do I fix it? Googling with terms like
OpenURI::HTTPError did not produce anything useful. It this a transient
error (web site offline) or a permenent one (watir gem URI mistyped)?

Any insight into this is appreciated.

Regards,
Jim


#2

This problem was fixed the other day. The cause was a misconfiguration
of the gem server. It was referencing a gem that wasn’t there. Tom
Copeland worked with me to fix it.

Bret


#3

I installed watir today and say the same thing. I think the gem must be
bad
on the server. I was able to get it to install by specifying a version:

gem install watir -v 1.4.1


#4

removed_email_address@domain.invalid wrote:

This problem was fixed the other day. The cause was a misconfiguration
of the gem server. It was referencing a gem that wasn’t there. Tom
Copeland worked with me to fix it.

Bret

I am also trying to update for watir (I just installed Ruby) and I am
getting another error:

gem install watir -v 1.5.4
ERROR: While executing gem … (Gem::RemoteSourceException)
HTTP Response 404

I cannot figure out what I haven’t done properly and would love a hand!

Natalie


#5

On Tue, 2008-06-17 at 03:38 +0900, Natalie Schluter wrote:

gem install watir -v 1.5.4
Hm, shouldn’t that be “gem install watir -v=1.5.4” ?

Yours,

tom


#6

On Mon, Jun 16, 2008 at 1:38 PM, Natalie Schluter
removed_email_address@domain.invalid
wrote:

I am also trying to update for watir (I just installed Ruby) and I am
getting another error:

gem install watir -v 1.5.4
ERROR: While executing gem … (Gem::RemoteSourceException)
HTTP Response 404

I cannot figure out what I haven’t done properly and would love a hand!

I don’t think you’ve done anything wrong. This error seems to indicate
that
the gem server is unavailable at the moment. If you try again, it should
work.

You might also want to consider using Watir 1.5.6, which is the latest.

Bret


#7

On Tue, Jun 17, 2008 at 6:20 AM, Natalie Schluter
removed_email_address@domain.invalid
wrote:

What do you think?

Natalie

Posted via http://www.ruby-forum.com/.

What happens if you just type “gem install watir”?

Is it possible that your access to the gem server is being blocked by a
firewall?

Bret


#8

Hi Bret,

What happens if you just type “gem install watir”?

I get exactly the same error.

Is it possible that your access to the gem server is being blocked by a
firewall?

I have played around with firewall setting that make no difference
locally. The administrator for the network I am on when using Unix (I
am using Windows now) tells me to check if the server is still on and
matches the gem version I am using, which brings me back to square
one…

Any suggestions?

Thanks,
Natalie


#9

On Tue, Jun 17, 2008 at 11:19 AM, Natalie Schluter
removed_email_address@domain.invalid
wrote:

Any suggestions?

Are you able to install any other gems?


#10

Tom C. wrote:

On Tue, 2008-06-17 at 03:38 +0900, Natalie Schluter wrote:

gem install watir -v 1.5.4
Hm, shouldn’t that be “gem install watir -v=1.5.4” ?

Yours,

tom

Thanks for the suggestions Bret and Tom. I tried those modifications
today, but still got the same error.

gem install watir -v=1.5.6
ERROR: While executing gem … (Gem::RemoteSourceException)
HTTP Response 404

gem install watir -v 1.5.6
ERROR: While executing gem … (Gem::RemoteSourceException)
HTTP Response 404

What do you think?

Natalie


#11

On Wed, 2008-06-18 at 01:19 +0900, Natalie Schluter wrote:

Hi Bret,

What happens if you just type “gem install watir”?

I get exactly the same error.

What if you browse to this URL?

http://gems.rubyforge.vm.bytemark.co.uk/gems/watir-1.5.6.gem

That should pull the gem file directly off that gem mirror…

Yours,

tom


#12

Hello, still me…

Are you able to install any other gems?

I tried this and get the same thing:

gem install ParseTree
ERROR: While executing gem … (Gem::RemoteSourceException)
HTTP Response 404

I also get the same error when I type

gem update --system
as well as several other commands (which need the internet I guess).

Tom, for that url, where should should I be putting the file (right now
it I’ve stuck it in ~/ruby/lib/ruby/gems/1.8/gems ), and what do I do
with it? I have tried untarring it, but I end up with two other
archived files data.tar.gz and metadata.gz. Also, I get the message for
both files, “implausibly old time stamp 1970-01-01 00:00:00”.

Thanks very much for your help!

Natalie


#13

OK, I’ll try that.
Thanks, Natalie


#14

On Wed, 2008-06-18 at 20:08 +0900, Natalie Schluter wrote:

Tom, for that url, where should should I be putting the file (right now
it I’ve stuck it in ~/ruby/lib/ruby/gems/1.8/gems ), and what do I do
with it? I have tried untarring it, but I end up with two other
archived files data.tar.gz and metadata.gz. Also, I get the message for
both files, “implausibly old time stamp 1970-01-01 00:00:00”.

Put the file in any directory - e.g., your home directory - and then
install it with:

sudo gem install --local watir-1.5.6.gem

Of course, there are a few dependencies, and you’ll need to fetch those
from the mirrors as well…

Yours,

tom