Warning dopo aggiornamento

Dopo aver eseguito l’aggiornamento sudo gem update all’avvio del server
webcrick viene restituito il seguente warning

/Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed
on or after August 2010. Use #requirement

Alessandro DB wrote:

Dopo aver eseguito l’aggiornamento sudo gem update all’avvio del server
webcrick viene restituito il seguente warning

/Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed
on or after August 2010. Use #requirement

Anche a me è successo con rubygems 1.3.6 e rails 2.3.5.
Ho risolto applicando questa patch:

http://github.com/rails/rails/commit/268c9040d5c3c7ed30f3923eee71a78eeece8a8a#diff-0

2010/3/1 Alessandro DB [email protected]:

Dopo aver eseguito l’aggiornamento sudo gem update all’avvio del server
webcrick viene restituito il seguente warning

/Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed
on or after August 2010. Use #requirement

Beh, direi che, molto probabilmente, da qui a cinque mesi uscirà una
nuova versione di rails…

pietro

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs