Warbler/tomcat RubyGems version problem


#1

Hi,

I’m new to packaging up jRuby apps with Warbler, so hopefully this is
just a newbie issue… I created a new project to start testing my
setup with jruby/warbler deploying to tomcat. I’m running jruby 1.1.5,
and warbler 0.9.11, deploying to tomcat 6.

I created my new project, modified only the layout and routes, and can
run jruby script/server and it looks just fine in webrick. I installed
warbler as a plugin, and run ‘rake war’ and it creates my war file
without errors. I then deploy the war in tomcat, and that seems to go
OK until I try and run it - at which point I get your standard rails
production-environment error message, and then I see this in the tomcat
logs:

INFO: Deploying web application archive WineCellar.war
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please gem update --system and try again.

I’ve verified that I have RubyGems 1.3.1 installed on the development
system - and if I run the ‘gem udpate --system’ there immediately before
creating the jar, it reports there’s nothing to update. Ive tried
removing /tmp/war to ensure that nothing old is getting
repacked into the war - but with no luck.

Can someone please tell me what I might be doing wrong?

Thanks!


#2

Hi.

I am experiencing the exact same problem and would really like some
help.

Thanks in advanced!