Warbler failing on me


#1

Hi there,

I’m having issues making warbler run.

What could be going on here?

Stefan

D:\projects\post-discrepancy>jruby -S warble --trace war
** Invoke war (first_time)
** Invoke war:app (first_time)
** Invoke war:gems (first_time)
** Invoke tmp/war/WEB-INF/gems/specifications/rails-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (first_time, not_needed)
** Invoke
C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/rails-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications/rake-0.8.3.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/rake-0.8.3.gemspec
(first_time, not_needed)
** Invoke
tmp/war/WEB-INF/gems/specifications/activesupport-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/activesupport-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications/activerecord-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/activerecord-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications/actionpack-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/actionpack-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications/actionmailer-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/actionmailer-2.2.2.gemspec
(first_time, not_needed)
** Invoke
tmp/war/WEB-INF/gems/specifications/activeresource-2.2.2.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/activeresource-2.2.2.gemspec
(first_time, not_needed)
** Execute war:gems
** Invoke tmp/war/WEB-INF/app (first_time, not_needed)
** Invoke tmp/war/WEB-INF/config (first_time, not_needed)
rake aborted!
Don’t know how to build task ‘lib’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1706:in
[]' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:770:inout_of_date?’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:770:in
each' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:770:inany?’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:770:in
out_of_date?' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:753:inneeded?’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:596:in
format_trace_flags' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:573:ininvoke_with_call_chain’
C:/jruby-1.1.6/bin/…/lib/ruby/1.8/monitor.rb:191:in mon_synchronize' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:ininvoke_with_call_chain’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
invoke_prerequisites' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:ineach’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
invoke_prerequisites' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:ininvoke_with_call_chain’
C:/jruby-1.1.6/bin/…/lib/ruby/1.8/monitor.rb:191:in mon_synchronize' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:ininvoke_with_call_chain’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
invoke_prerequisites' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:ineach’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
invoke_prerequisites' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:ininvoke_with_call_chain’
C:/jruby-1.1.6/bin/…/lib/ruby/1.8/monitor.rb:191:in mon_synchronize' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:ininvoke_with_call_chain’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in
invoke' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:ininvoke_task’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
top_level' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:ineach’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
top_level' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:instandard_exception_handling’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1991:in
top_level' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/aslakhellesoy-warbler-0.9.13/bin/warble:67 C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:instandard_exception_handling’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/aslakhellesoy-warbler-0.9.13/bin/warble:26
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/aslakhellesoy-warbler-0.9.13/bin/warble:19:in
`load’
C:\jruby-1.1.6\bin…\bin\warble:19


#2

I think I had that problem before. My problem was that there was some
sort
of jdbc rake file under my lib folder. It could be the same thing that
is
happening to you. Do you have anything under your rails’ lib folder?

Best regards,
Juan P. Tarquino

On Fri, Feb 6, 2009 at 9:00 AM, Stefan Magnus Landrø <


#3

Solved it. The lib folder was missing in my rails application.

Stefan

2009/2/6 Juan P. Tarquino removed_email_address@domain.invalid


#4

Can you file a quick JIRA for that? Seems like Warbler could be a little
more forgiving.

Stefan Magnus Landrø wrote:

    I'm having issues making warbler run.
    tmp/war/WEB-INF/gems/specifications/rails-2.2.2.gemspec
    C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/rake-0.8.3.gemspec
    (first_time, not_needed)
    (first_time, not_needed)
    ** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
    C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:770:in
    `format_trace_flags'
    C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
    `each'
    C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in
    `top_level'
    Bekk Open Source
    http://boss.bekk.no


Bekk Open Source
http://boss.bekk.no


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#5

http://jira.codehaus.org/browse/JRUBY-3382

2009/2/6 Charles Oliver N. removed_email_address@domain.invalid


#6

No need for a ticket, I’ve got a quick fix coming.

/Nick

On Fri, Feb 6, 2009 at 9:07 AM, Charles Oliver N.
removed_email_address@domain.invalid wrote:

mailto:removed_email_address@domain.invalid>
On Fri, Feb 6, 2009 at 9:00 AM, Stefan Magnus Landrø
<removed_email_address@domain.invalid mailto:removed_email_address@domain.invalid> wrote:
** Invoke war (first_time)
** Invoke tmp/war/WEB-INF/gems/specifications/rake-0.8.3.gemspec

   ** Invoke
   ** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)

C:/jruby-1.1.6/lib/ruby/gems/1.8/specifications/activeresource-2.2.2.gemspec
out_of_date?' C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:573:ininvoke_prerequisites’
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
C:/jruby-1.1.6/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#7

Sorry Nick, saw your message too late.

Could you integrate the changes that Aslak has too?
http://github.com/aslakhellesoy/warbler/tree/master

Stefan

2009/2/6 Nick S. removed_email_address@domain.invalid