Warbler error


#1

My attempts to use warbler fail consistently on both Windows and RHEL 5
Linux, with the error below. It looks similar to the “lib” error that
people were having a few months back, but in my case Rake is reporting
that it can’t build ‘’.

Environment: jruby-1.2.0, rails 2.3.2, rake 0.8.4

Also, for what it’s worth, rake war:app and rake war:gems both produce
this error. The other warbler-related tasks don’t.

[jruby_admin@dvltps019 current]$ rake war --trace
(in /home/jruby_admin/rails_apps/contracts/releases/2009052201)
** Invoke environment (first_time)
** Execute environment
** Invoke war (first_time)
** Invoke war:app (first_time)
** Invoke war:gems (first_time)
** Invoke tmp/war/WEB-INF/gems/specifications/ (first_time)
** Invoke tmp/war/WEB-INF/gems (first_time, not_needed)
rake aborted!
Don’t know how to build task ‘’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1704:in
[]' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:586:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in
each' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/1.8/monitor.rb:191:inmon_synchronize’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:588:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in
each' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/1.8/monitor.rb:191:inmon_synchronize’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:588:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in
each' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/1.8/monitor.rb:191:inmon_synchronize’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:588:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in
each' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:ininvoke_prerequisites’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/1.8/monitor.rb:191:inmon_synchronize’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in
invoke_with_call_chain' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:564:ininvoke’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2027:in
invoke_task' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2005:intop_level’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2005:in
each' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2005:intop_level’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2044:in
standard_exception_handling' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1999:intop_level’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1977:in
run' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2044:instandard_exception_handling’
/home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1974:in
run' /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/bin/rake:31 /home/jruby_admin/jruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rake-0.8.4/bin/rake:19:inload’
/home/jruby_admin/jruby/jruby-1.2.0/bin/rake:19
[jruby_admin@dvltps019 current]$


#2

hi there,

I have the same issue with the config.gem entries in environment.rb.

Environment: Mac OSX,warbler-0.9.13,jruby 1.3.0RC2,rake-0.8.7,rails
2.3.2

any help appreciated.

regards johannes

** Invoke war:gems (first_time)
** Invoke
tmp/war/WEB-INF/gems/specifications/thoughtbot-shoulda-2.10.1.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (first_time, not_needed)
** Invoke
/Users/johannes/jruby/lib/ruby/gems/1.8/specifications/thoughtbot-shoulda-2.10.1.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications/ruby-openid-2.1.6.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
/Users/johannes/jruby/lib/ruby/gems/1.8/specifications/ruby-openid-2.1.6.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications/authlogic-2.0.13.gemspec
(first_time, not_needed)
** Invoke tmp/war/WEB-INF/gems/specifications (not_needed)
** Invoke
/Users/johannes/jruby/lib/ruby/gems/1.8/specifications/authlogic-2.0.13.gemspec
(first_time, not_needed)
rake aborted!
Don’t know how to build task ‘’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1728:in
[]' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:787:inout_of_date?’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:787:in
each' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:787:inany?’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:787:in
out_of_date?' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:771:inneeded?’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:615:in
format_trace_flags' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:592:ininvoke_with_call_chain’
/Users/johannes/jruby/lib/ruby/1.8/monitor.rb:191:in mon_synchronize' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:ininvoke_with_call_chain’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in
invoke_prerequisites' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:ineach’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in
invoke_prerequisites' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:ininvoke_with_call_chain’
/Users/johannes/jruby/lib/ruby/1.8/monitor.rb:191:in mon_synchronize' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:ininvoke_with_call_chain’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in
invoke' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:ininvoke_task’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
top_level' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:ineach’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
top_level' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:instandard_exception_handling’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in
top_level' /Users/johannes/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.13/bin/warble:67 /Users/johannes/jruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:instandard_exception_handling’
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.13/bin/warble:26
/Users/johannes/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.13/bin/warble:19:in
`load’


#3

Johannes H. wrote:

hi there,

I have the same issue with the config.gem entries in environment.rb.

Environment: Mac OSX,warbler-0.9.13,jruby 1.3.0RC2,rake-0.8.7,rails
2.3.2

any help appreciated.

Upgrading to jruby-rack-0.9.4.jar (from 0.9.3) appears to have resolved
this issue (and a few other mysteries) on my system.