Warble aborted please help

I have three applications.
I’m using jruby-1.6.2, rails-3.0.7 and warbler-1.3.0.
The OS is linux debian and java is openjdk.
I run bundle exec warble on two of these applications and the war file
is created with no problems.
The third application is very small becaus I’m starting to develop it
but when I run bundle exec warble it says:

warble aborted!
Error: Your application used more memory than the safety cap of 500m.
Specify -J-Xmx####m to increase it (#### = cap size in MB).
Specify -w for full OutOfMemoryError stack trace

Please help because I need to put the application in production but if
I can’t create the war I’m in problems.
If you want I can send the entire application code, it is in its
starting point so there is no much code.
The Gemfile fot all three applications is just the same so I really
don’t understand why warble works for two applications but not for the
third.

On 30 May 2011 10:38, Mauro [email protected] wrote:

Specify -J-Xmx####m to increase it (#### = cap size in MB).
Specify -w for full OutOfMemoryError stack trace

The problem seems to be rake-0.9.0.
I’ve installed warbler-1.3.1 that require rake-0.8.7 and the problem is
solved.
I had not found any doc regarding the problem with rake.0.9.0 and
warbler.

There’s been alot of discussion about the incompatibility changes with
Rake
from 0.8.7 and 0.9.0 and how gem versioning is being tackled. I suggest
reading this article to get a feel for what gem developers are going
through
and what you might be able to glean from it:

http://blog.davidchelimsky.net/2011/05/28/rake-09-and-gem-version-constraints/

-Nick K.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs