Vr run error

I am currently trying to get vr up and running on Ubuntu 12.04.2
Virtualbox
I am running ruby 2.0.0
I have re-installed ‘builder’ gem thinking that that may be the problem.

Successfully installed builder-3.2.0

but when i try to run vr I still get the same error. Im pretty lost at
this point any help would be appreciated!

(not sure if this matters but Im running Ubuntu on top of Virtualbox on
a 2011 mbp i5 2.3)

[email protected]:~$ vr
/home/scott/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in
require': cannot load such file -- rubygems/builder (LoadError) from /home/scott/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:inrequire’
from
/home/scott/.rvm/gems/ruby-2.0.0-p0/gems/visualruby-0.1.2/vr:15:in <top (required)>' from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/vr:19:inload’
from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/vr:19:in <main>' from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:ineval’
from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in
`’

Scott H. wrote in post #1108807:

I am currently trying to get vr up and running on Ubuntu 12.04.2
Virtualbox
I am running ruby 2.0.0
I have re-installed ‘builder’ gem thinking that that may be the problem.

Successfully installed builder-3.2.0

but when i try to run vr I still get the same error. Im pretty lost at
this point any help would be appreciated!

(not sure if this matters but Im running Ubuntu on top of Virtualbox on
a 2011 mbp i5 2.3)

[email protected]:~$ vr

/home/scott/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in

`require’: cannot load such file – rubygems/builder (LoadError)
from

/home/scott/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in

require' from /home/scott/.rvm/gems/ruby-2.0.0-p0/gems/visualruby-0.1.2/vr:15:in<top
(required)>’
from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/vr:19:in load' from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/vr:19:in
from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in
eval' from /home/scott/.rvm/gems/ruby-2.0.0-p0/bin/ruby_noexec_wrapper:14:in

Hi Scott,

You can edit the “vr” file in
/home/scott/.rvm/gems/ruby-2.0.0-p0/gems/visualruby-0.1.2/vr to fix this
issue.
I edited the “vr” file to require “builder” instead of require
“rubygems/builder”

Hi Clouds:

Should I make this change in all the versions of visualruby?

I don’t understand the implications of your change.

I have these four lines in the vr file:

require “rubygems/installer”
require “rubygems/uninstaller”
require “rubygems/builder”
require “rubygems/specification”

Should I change them?

Thanks,
Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs