VOLK configure error in OSX 10.8

I’m running OSX 10.8.0, Xcode 4.4, latest updates; all background
dependencies are installed as both 32 and 64 bit, and includes “orc”.
Please let me know what tests I can run to get more/better info to help
correct this issue. - MLD

% clang --version
Apple clang version 4.0 (tags/Apple/clang-421.0.57) (based on LLVM
3.1svn)
Target: x86_64-apple-darwin12.0.0
Thread model: posix

% gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build
5658) (LLVM build 2336.11.00)

% uname -a
Darwin mld-mbp-17.comcast.net 12.0.0 Darwin Kernel Version 12.0.0: Sun
Jun 24 23:00:16 PDT 2012; root:xnu-2050.7.9~1/RELEASE_X86_64 x86_64

% cmake …/git
[snip]
– Compiler name: GNU
– x86* CPU detected
– GCC missing xgetbv, Overruled arch avx
– CPU width is 64 bits, Overruled arch 32
– Available architectures:
generic;altivec;neon;64;3dnow;abm;popcount;mmx;sse;sse2;orc;norc;sse3;ssse3;sse4_a;sse4_1;sse4_2
– Available machines:
generic_orc;neon_orc;sse2_64_mmx_orc;sse3_64_orc;ssse3_64_orc;sse4_a_64_orc;sse4_1_64_orc;sse4_2_64_orc;altivec
– Using install prefix: /usr/local
[snip]

% make VERBOSE=on
[snip]
/opt/local/bin/cmake -H/opt/GNURadio/source/git
-B/opt/GNURadio/source/builds/10.8 --check-build-system
CMakeFiles/Makefile.cmake 0
/opt/local/bin/cmake -E cmake_progress_start
/opt/GNURadio/source/builds/10.8/CMakeFiles
/opt/GNURadio/source/builds/10.8/CMakeFiles/progress.marks
make -f CMakeFiles/Makefile2 all
make -f volk/lib/CMakeFiles/volk.dir/build.make
volk/lib/CMakeFiles/volk.dir/depend
cd /opt/GNURadio/source/builds/10.8 && /opt/local/bin/cmake -E
cmake_depends “Unix Makefiles” /opt/GNURadio/source/git
/opt/GNURadio/source/git/volk/lib /opt/GNURadio/source/builds/10.8
/opt/GNURadio/source/builds/10.8/volk/lib
/opt/GNURadio/source/builds/10.8/volk/lib/CMakeFiles/volk.dir/DependInfo.cmake
–color=
make -f volk/lib/CMakeFiles/volk.dir/build.make
volk/lib/CMakeFiles/volk.dir/build
/opt/local/bin/cmake -E cmake_progress_report
/opt/GNURadio/source/builds/10.8/CMakeFiles
[ 0%] Building C object
volk/lib/CMakeFiles/volk.dir/volk_machine_neon_orc.c.o
cd /opt/GNURadio/source/builds/10.8/volk/lib && /usr/bin/gcc
-Dvolk_EXPORTS -DHAVE_FENV_H -DHAVE_DLFCN_H -O3 -DNDEBUG -fPIC
-I/opt/GNURadio/source/builds/10.8/volk/include
-I/opt/GNURadio/source/git/volk/include
-I/opt/GNURadio/source/builds/10.8/volk/lib
-I/opt/GNURadio/source/git/volk/lib -I/opt/local/include/orc-0.4
-I/opt/local/include -fvisibility=hidden -mfpu=neon
-mfloat-abi=softfp -funsafe-math-optimizations -o
CMakeFiles/volk.dir/volk_machine_neon_orc.c.o -c
/opt/GNURadio/source/builds/10.8/volk/lib/volk_machine_neon_orc.c
cc1: error: unrecognized command line option “-mfpu=neon”
cc1: error: unrecognized command line option “-mfloat-abi=softfp”
make[2]: *** [volk/lib/CMakeFiles/volk.dir/volk_machine_neon_orc.c.o]
Error 1
make[1]: *** [volk/lib/CMakeFiles/volk.dir/all] Error 2
make: *** [all] Error 2

On 08/06/2012 09:43 AM, Michael D. wrote:

I’m running OSX 10.8.0, Xcode 4.4, latest updates; all background
dependencies are installed as both 32 and 64 bit, and includes “orc”.
Please let me know what tests I can run to get more/better info to
help correct this issue. - MLD

I recall seeing this once before, we never resolved it:
http://www.ruby-forum.com/topic/4216278

It looks like we could check if the compiler is clang and add:
-Werror=unused-command-line-argument

what does ${CMAKE_C_COMPILER_ID} yield for you in cmake land?

-josh

Looking at the CMakeCache.txt file, I don’t see CMAKE_C_COMPILER_ID. I
do see:

//CXX compiler.
CMAKE_CXX_COMPILER:FILEPATH=/usr/bin/c++

//C compiler.
CMAKE_C_COMPILER:FILEPATH=/usr/bin/gcc

which result in:

% /usr/bin/c++ --version
Apple clang version 4.0

% /usr/bin/gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build
5658) (LLVM build 2336.11.00)

So, I think CMake is getting confused by the different compiler names.
“/usr/bin/g++” does indeed link to GCC, while “/usr/bin/cc” links to
clang, if that helps.

I also forgot to mention that this was using the latest GIT master for
GNU Radio, and UHD is installed and seems to work w/o modification. -
MLD

On 08/06/2012 02:15 PM, Michael D. wrote:

% /usr/bin/c++ --version
Apple clang version 4.0

% /usr/bin/gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658)
(LLVM build 2336.11.00)

So, I think CMake is getting confused by the different compiler names.
“/usr/bin/g++” does indeed link to GCC, while “/usr/bin/cc” links to clang, if
that helps.

I also forgot to mention that this was using the latest GIT master for GNU
Radio, and UHD is installed and seems to work w/o modification. - MLD

There should be a print out in the configure verbose, can you attach it?

set(COMPILER_NAME ${CMAKE_C_COMPILER_ID})
if(MSVC) #its not set otherwise
set(COMPILER_NAME MSVC)
endif()

message(STATUS “Compiler name: ${COMPILER_NAME}”)

On Mon, Aug 6, 2012 at 6:43 AM, Michael D. [email protected]
wrote:

% uname -a
– Using install prefix: /usr/local
/opt/local/bin/cmake -E cmake_progress_report
/opt/GNURadio/source/builds/10.8/CMakeFiles
Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

I’m having this issue now. How did you get it working?

Cheers,
Ben

mailing list [email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

I’m having this issue now. How did you get it working?

Supposedly this patch fixed it, but how did it work…? Its missing a
critical variable substitution:
http://gnuradio.org/cgit/gnuradio.git/commit/?h=next&id=31e992a2850450121199169f8538f28b2f634cd7

Can you cherry pick this commit onto whatever maint/master/next branch
you have checkedout?
http://gnuradio.org/cgit/jblum.git/commit/?h=fix_volk_flag_check&id=e347c66d7372f70e47870f6002a223f71dfd7b9d

-josh

Josh checked some change(s) in, and it/they seem/s to work. I haven’t
looked further, since GNU Radio compiles for me on 10.8 now (10.8.1,
XCode 4.4.1). “make test” works again on everything except UDP, but I
have tried none of the examples or my own code yet. Sorry I cannot be
more precise. If you’re still having issues after Josh’s latest, send
me an email off-list and I’ll try to help you work it out. - MLD

On Sep 10, 2012, at 3:05 AM, Ben R. [email protected] wrote:

[ 0%] Building C object volk/lib/CMakeFiles/volk.dir/volk_machine_neon_orc.c.o
cd /opt/GNURadio/source/builds/10.8/volk/lib && /usr/bin/gcc -Dvolk_EXPORTS
-DHAVE_FENV_H -DHAVE_DLFCN_H -O3 -DNDEBUG -fPIC
-I/opt/GNURadio/source/builds/10.8/volk/include
-I/opt/GNURadio/source/git/volk/include
-I/opt/GNURadio/source/builds/10.8/volk/lib -I/opt/GNURadio/source/git/volk/lib
-I/opt/local/include/orc-0.4 -I/opt/local/include -fvisibility=hidden
-mfpu=neon -mfloat-abi=softfp -funsafe-math-optimizations -o
CMakeFiles/volk.dir/volk_machine_neon_orc.c.o -c
/opt/GNURadio/source/builds/10.8/volk/lib/volk_machine_neon_orc.c

cc1: error: unrecognized command line option “-mfpu=neon”
cc1: error: unrecognized command line option “-mfloat-abi=softfp”
make[2]: *** [volk/lib/CMakeFiles/volk.dir/volk_machine_neon_orc.c.o] Error 1
make[1]: *** [volk/lib/CMakeFiles/volk.dir/all] Error 2
make: *** [all] Error 2

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs